Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Ubuntu 14.04 (Trusty Tahr) along with Windows 8.1. When I turn on the computer I don't get an option to boot into Ubuntu, and I go strait into Windows. How can I solve this?

I have tried using boot-repair, but I could not install it on live Ubuntu (as the Internet connection is not working), so it is working in my 'installed' version of Ubuntu. There I am not able to use the 'recommended repair' option.

Here is my pastebin link: http://paste.ubuntu.com/15306542/

share|improve this question
    
Looks like you simply have to install the GRUB boot loader to /dev/sda. Probably you selected something else in the installer (probably /dev/sda7). – Byte Commander Mar 6 at 12:51
3  
    
You have an HP, which violates UEFI spec and uses description to boot. You need to create /EFI/Boot/bootx64.efi that really is shimx64.efi and boot hard drive or fallback entry in UEFI. askubuntu.com/questions/486752/… and: askubuntu.com/questions/597052/… – oldfred Mar 6 at 16:02

Step 1 : Disable hibernation and fast startup in Windows.

Open command prompt as administrator and execute :

powercfg /h off  

Open Windows Control Panel.
Go to the Power Settings.
Uncheck Fast startup.

Step 2 : Shutdown the machine completely - do NOT reboot.

Step 3 : Reinstall GRUB boot loader for Ubuntu in EFI mode.

Boot from Ubuntu installation media.
Select Try Ubuntu without installing.
Open a terminal and execute:

sudo mount /dev/sda7 /mnt
sudo mount /dev/sda2 /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
grub-install /dev/sda
update-grub  

Note:

sda = disk | sda2 = efi partition | sda7 = system partition

Step 4 : Boot into BIOS and select Ubuntu as default system.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.