Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to bind my mouses XF86Search button to toggle/open the Guake terminal (it's the F12 key by default). So while I was running Ubuntu 10.04 this was working out of the box...I just had to install Guake and go into Guake Preferences and set the key by pushing it on the mouse (like every other key). On Ubuntu 11.10 I get this message:

Key binding error

Unable to bind global XF86Search key

I am guessing this is related to some config in Ubuntu (maybe to key is already mapped to something so I can't remap it?). Any ideas how to get this to work again?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The XF86Search key is set to Search in the Launchers section of Keyboard in the System setting panel. Try to unset that first.

Go to System Settings (or run 'gnome-control-center' from a command line). Select 'Keyboard' -> 'Shortcuts' -> 'Launchers' then select Search and press Backspace to clear the shortcut.

I have no idea if this will fix your problem but it's worth a try.

share|improve this answer
    
Yup thank you that fixed it! –  Icoo Oct 31 '11 at 19:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.