Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Since I upgraded to Ubuntu 11.10 from 11.04 I get GTK and GLib errors while trying to run a kernel menuconfig using OpenEmbedded.

I'm asking it here as I think these errors are caused by some change from 11.04 to 11.10 version, not because of the specific issue with OpenEmbedded.

Here's an example of the errors I get:

| (gnome-terminal:19575): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1230:46: Couldn't recognize the image file format for file '/usr/share/themes/Ambiance/gtk-3.0/assets/slider.png'
| (gnome-terminal:19575): GLib-GIO-CRITICAL **: Settings schema 'org.gnome.system.proxy' is not installed
| (gnome-terminal:19575): GLib-CRITICAL **: g_variant_get_va: assertion `value != NULL' failed
| (gnome-terminal:19575): Pango-CRITICAL **: pango_font_description_from_string: assertion `str != NULL' failed

Interestingly, if I change my Gnome theme from Ambiance (which uses png images) to High Contrast, the first type of error disappears.

Any experience with these compatibility issues?

share|improve this question

1 Answer 1

I also experience the same problem with Ubuntu 11.10. OE devshell worked for me with 11.04. I got around the problem by adding


in my local.conf.

share|improve this answer
I tried it but I still get the same error when I launch "bitbake -c menuconfig linux-at91sam9x5ek", where linux-at91sam9x5ek is the name of my distro – stef Nov 3 '11 at 18:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.