Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I want to install MonoDevelop 2.10 and I have cloned the current release with git clone git:// however running ./configure I get the error:

configure: error: Please install mono version 2.8 or later to install MonoDevelop.
Please see to download latest mono sources or packages

Although I have Ubuntu 11.10 with Mono JIT compiler version 2.10.5 (Debian 2.10.5-1) (output of mono --version) this error seems to be trolling me. Can anyone explain me, what error drives me crazy?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You likely need mono-devel installed though that may not be the end of your configure issues. Maybe just go ahead & run

sudo apt-get build-dep monodevelop
share|improve this answer
Works fine! (Just thought that the IDE should be version 2.10 and not 2.8 as Mono itself is version 2.10...) – Christian Ivicevic Oct 31 '11 at 16:06
Its 2013 and I'm still facing this very same issue on Ubuntu 12.04 LTS. Maybe this will change some day!! – Prahlad Yeri Apr 6 '13 at 23:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.