Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install the Aventail tunnel client to connect to my workplace server. I'm getting the following error when I run the installer script:

Using certificates in /etc/ssl/certs
One or more dependencies cannot be resolved.
Aventail Connect install failed.
To uninstall, run /usr/local/Aventail/

Error details: =>  (0x0049e000) => /lib/i386-linux-gnu/ (0x00a40000) => not found => not found => /lib/i386-linux-gnu/ (0x00c41000) => /usr/lib/i386-linux-gnu/ (0x00110000) => /lib/i386-linux-gnu/ (0x00e8f000) => /lib/i386-linux-gnu/ (0x0074b000) => /lib/i386-linux-gnu/ (0x00a93000)
    /lib/ (0x00257000)

I'm trying to install all missing libraries, but to no avail. For example, if I do:

sudo aptitude install libssl-dev

I get the same result.

What does this means?

I'm seriusly -SERIUSLY- beggining to considering leaving ubuntu and going back to slackware. I've lost about a week's work. First I had to reinstall the system after an upgrade, unluckly decided to install the newest version, and now I cannot even connect to the server. And I'm not speaking about the changes in the window manager.

Seriously, the new nice window manager is great for my wife and son. But for enterprise things, to change constantly is not good. Just a comment from a long time linux user.

share|improve this question
up vote 1 down vote accepted

Looks like your program is a 32-bit binary. Install the 32-bit SSL library and you'll be ready to continue:

sudo apt-get install libssl0.9.8:i386
share|improve this answer

After installing libssl0.9.8 need to create the symbolic links to point and to and respectively.

sudo ln -s /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/

sudo ln -s /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/

You can query the installed location of libssl0.9.8 by dpkg-query -L libssl0.9.8:i386

share|improve this answer

For 64-bit:

sudo apt-get install libssl0.9.8

sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/

sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/

and then reinstall should solve the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.