Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed gstreamer-vaapi from this PPA :

ppa:guido-iodice/video

sudo apt-get install gstreamer0.10-vaapi libgstvaapi-x11-0 libgstvaapi0

but, if I run totem movie player (via terminal) it's show this error :

(totem:3383): GLib-GObject-WARNING **: g_object_set_valist: object class 'TotemScrsaver' has no property named 'reason'

(totem:3383): GLib-GObject-WARNING **: value "10752000" of type 'guint' is invalid or out of range for property 'connection-speed' of type 'guint' libva: libva version 0.31.0 Xlib: extension "XFree86-DRI" missing on display ":0.0". libva: va_getDriverName() returns 0 libva: Trying to open /usr/lib/dri/nvidia_drv_video.so libva error: /usr/lib/dri/nvidia_drv_video.so init failed libva: va_openDriver() returns -1 Segmentation fault

It's seems I get wrong nvidia_drv_video.so. What should I do?

If I uninstall it, it's work fine, but I want to use this vaapi backend for my video decoding via GPU while I run gstreamer based apps.

PS :

I use Ubuntu Lucid 64bit and MSI CR 400 Notebook :

  • Intel Core 2 Duo
  • Nvidia 8200M
share|improve this question
add comment

2 Answers 2

If you are certainly using the nvidia proprietary driver then it's probably a problem with the PPA package and you should report the problem to Guido Iodice:

https://launchpad.net/~guido-iodice

share|improve this answer
add comment

Before install driver or other software - need down gui, possible example for ubuntu: $ sudo service gdm stop $ sudo ... install drivers ... $ sudo reboot $ sudo service gdm stop $ sudo ... install software ... $ sudo reboot $ sudo ... test you media player

P.S. Sorry for my bad english

tvlm@jubber.ru

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.