Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Toshiba L745D (AMD A6-3400M). I cannot get my internal mic to work.

My sound card: Conexant CX20585

I've tried this:

echo "options snd-hda-intel model=thinkpad" | sudo tee -a /etc/modprobe.d/alsa-base.conf

echo "options snd-hda-intel model=ideapad" | sudo tee -a /etc/modprobe.d/alsa-base.conf

echo "options snd-hda-intel model=asus" | sudo tee -a /etc/modprobe.d/alsa-base.conf

...but that didn't work either. Apparently that works for different notebook models with the same sound card. I also tried muting the right mic channel; that also worked for someone on a different model.

Here is my ALSA information:

http://www.alsa-project.org/db/?f=6b57a7faecf5525ccb5212a6f60ee9d1bc792838

Any solutions out there?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Upon further research, people with Windows 7 have also been experiencing this bug also with the default install; I reinstalled Windows 7 and used the default sound card drivers instead of the official Conexant drivers and that's why I think my mic worked in Windows 7.

If you have 'Fast Boot' enabled in the BIOS Ubuntu will not recognize the microphone. Here is my ALSA information after I switched back to 'Normal Boot':

http://www.alsa-project.org/db/?f=0e81ce3afc0effc162ae19c608137bd5969a0f44

And the good news is that my internal microphone is now working, but I had to reinstall Ubuntu to get my microphone working unfortunately.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.