Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Ubuntu 15.10 on a Toshiba Chromebook. The keyboard has no F11 key. The F4 key has the fullscreen icon because thats what Chrome OS uses, so I would like to use that to make applications fullscreen. I'm mostly talking about Chromium right now.

I've been playing around with xmodmap and I've seen alot of stuff talking about Ctrl, Super and Alt, but those seem to be different than F* and most other keys.

This is the last thing I tried:

:~$ xmodmap -pke | grep F11 
keycode  95 = F11 F11 F11 F11 F11 F11 XF86Switch_VT_11
:~$ xmodmap -pke | grep F4
keycode  70 = F4 F4 F4 F4 F4 F4 XF86Switch_VT_4
:~$ xmodmap -e "keycode 70 = F11 F11 F11 F11 F11 F11 XF86Switch_VT_11"
:~$ xmodmap -pke | grep 70
keycode  70 = F11 F11 F11 F11 F11 F11 XF86Switch_VT_11

After this F4 still doesn't make Chromium full screen. I don't really know what I'm doing, just picking and choosing from Google and man xmodmap.

How can I make F4 act like F11 for applications?

share|improve this question
up vote 2 down vote accepted

The way I'd approach that is to open Settings -> Keyboard -> Shortcuts -> Custom, and add a new shortcut, linking it to the following command

bash -c "xdotool getactivewindow key F11"

You will need xdotool to be installed , so run sudo apt-get install xdotool.

This has limitations, howver. This works only in GUI, won't work in TTY1 or terminal emulators.

share|improve this answer
    
That's works perfectly! I'm only concerned with the GUI for this so it totally fits the bill. Thanks a lot. – dan08 Feb 28 at 4:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.