Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to Ubuntu 11.10, I once right-clicked on a folder and told it to open the folder with Movie Player ("Open with other application...").

No harm done there, right? Nope, now Ubuntu opens folders with Movie Player instead of Nautilus. If I plug in a thumb drive, Movie Player opens.

If I click on the trash icon... Movie Player! The default action for opening a folder has somehow become Movie Player. Clicking on the "Home Folder" icon still opens Nautilus and opening a folder in Nautilus stays in Nautilus, but other links to folders automatically open Movie Player. How can I change this back?

share|improve this question
add comment

3 Answers 3

up vote 3 down vote accepted

Answer edited out from the question

Solution was obvious, in Nautilus I select a folder, right click, Open with other application, and pick "Files" which is apparently the name for Nautilus. Now that set the default back... until next time! I guess this is a cautionary tale.

share|improve this answer
add comment

In your home folder go to .local/share/applications/mimeapps.list It is a hidden file. You can unhide it with the following keyboard shortcut: Ctrl + H .

You then need to modify the line inode/directory=movie-player.desktop; or something like that, to inode/directory=nautilus-folder-handler.desktop; and save the file.

share|improve this answer
add comment

My original problem was that right-click "Open Containing Folder" didn't work for me in Banshee or File Roller on Ubuntu 13.10 64-bit. The dialog was a Shotwell dialog saying "unable to open folder". I tried deleting ~/.local/share/applications/mimeapps.list but that just forgot all my default application settings and had no effect on my original problem.

Here's what worked (I marked some things as "No Effect" meaning that I think these steps are unnecessary, but I can't be sure):

  • I uninstalled shotwell sudo apt-get remove shotwell then reinstalled it again sudo apt-get install shotwell. Now "Open Containing Folder" opened wrongly in Disk Usage Analyzer (baobab)

  • No Effect: I added nautilus.desktop to this line in mimeapps.list: inode/directory=nautilus-folder-handler.desktop;nautilus.desktop;

  • No Effect: I tried uninstalling and re-installing nautalis sudo apt-get remove nautilus nautilus-folder-handler sudo apt-get install nautilus nautilus-sendto nautilus-share I suspect this was a waste of time.

  • I uninstalled Disk Usage Analyzer sudo apt-get remove baobab and reinstalled it apt-get install baobab and that fixed it!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.