Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu on an old IBM ThinkPad R40 after trying it out by booting it from a USB drive. Everything worked perfectly, I had no issues whatsoever, so i used the icon on the desktop to Install it. during the install i got a CD drive error, but because i'm using a USB i didnt give it much thought. The isntall completes, and it asks me to reboot.

After i reboot, i get my BIOS splash, and then a black screen with the blinking underscore like the one you see on a command prompt. that's as far as it ever gets. no errors, no error tones, no apparent failure of any kind, it just stops. it was left to sit for sever hours with no results.

since then i've tried installs on multiple different hard drives. i have formatted with ext4 and then tried installing. nothing works. this is the most bizarre issue i've had to deal with in years. i have no idea how to fix this, any help or insight would be greatly appreciated.

[UPDATE] after further reading i see that often people are told to hold down shift to get into the GRUB menu. holding down shift for any length of time has proven completely inefective. if i hold it down during reboot, i get a "stuck key" error, if i hold it down after BIOS splash, nothing happens. nor does Shift-E

share|improve this question

I have ended up downloading and installing 10.04. which is running without any problems. all further attempts to fix 11.10 ended with the same problem. thank you all for your help, but i'm not too worried about it at the moment because my laptop works now.

share|improve this answer

First you should eliminate any hardware problem. You mention booting from a USB drive, can you attach that drive to another system and verify that it spins up and can be accessed?

Next, can you use TAB or Esc or Del to get into the BIOS screen? There may be a way to test access to the HW, although many do not have the ability to view USB devices.

Third try booting from something else - hard drive, another USB drive, CD/DVD.

If all three of those appear successful you may have a problem with the kernel improperly initializing the hardware. You might could use the third option (booting from another device) to modify kernel options within grub to fix it. With no output on the screen though you may be shooting in the dark.

share|improve this answer
I had eliminated hardware issues. I have three different hard drives, and three different laptops. prior to installing Ubuntu, All my harddrives had Windows XP on them, and all of them would boot, in any of my laptops. since then i have insstalled Ubuntu on two of the hard drives. neither of which will boot in any of my laptops, but the XP drive still does. The BIOS can still detect my harddrive on bootup. and i can still boot to my USB drive if nessecary. so i guess i'm doing that, and trying to fix it from there through grub. I'm also downloading 10.04 LTS, to see if i have any more luck. – Kain Oct 31 '11 at 20:06

When I first upgraded to 11.10, LightDM (the new login manager) wasn't coming up properly.

If this is what is affecting you, here are some ideas:

Try Ctrl+Alt+F1 to switch to tty1. If that shows a login prompt, login and then type 'startx'.

If that doesn't work, you could try logging in to tty1 and typing 'sudo gdm start'.

If Ctrl+Alt+F1 doesn't get you to a login prompt, then you are dealing with a different problem than I was.

share|improve this answer

UPDATE: So previously, I mentioned that my computer wouldn't boot into Unity after a fresh Ubuntu 11.10 install. The only thing that worked was doing another fresh install, but not checking the download updates and install 3rd party boxes. Just wanted to add that I was able to install the Ubuntu restricted extras and do a full software update AS WELL AS install the nvidia driver and my laptop is still booting up just fine.

Sooooo... if you are running into this problem, try doing a fresh install without checking any of the extra boxes. Not exactly sure why it works, but it did for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.