Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed LXDE in Ubuntu 11.10, so that I can choose it at the login screen, but I've since noticed that there's no compose key (since I enabled it in Gnome Shell and Unity) so I was wondering how to enable a compose key?

Thanks for any help :)

share|improve this question

3 Answers 3

up vote 7 down vote accepted

setxkbmap -option "compose:caps" for CapsLock

setxkbmap -option "compose:ralt" for right alt =)

share|improve this answer
1  
Hi, I did that for the right alt, but then I did it for the right ctrl instead, is there anyway to get rid of the one for the right alt, as now I can't use the Euro sign, as Alt gr doesn't work anymore, thanks :) –  Jack Fifield Nov 5 '11 at 16:15
    
This messes up other keys on my machine. –  l0b0 Apr 12 '12 at 15:00
    
This doesn't work for my with Lubuntu in a Virtualbox. Instead altgr opens up the context menu. Any further suggestions? How do I tell if the setting was correctly applied? How can I tell LXDE to unbind the menu behavior from AltGr? –  HansHarhoff Jan 27 at 12:49

You can check if the keyscan code on your keyboard same as default setting. Did you check if you can do the compose by selecting predefined keyboard with Compose key?

share|improve this answer

First set the compose key:

sudo leafpad /etc/default/keyboard

and change to

XKBMODEL="pc105"
XKBLAYOUT="gb"
XKBVARIANT=""
XKBOPTIONS="compose:Shift+AltGr"   
#use another key
if you wish list http://www.autohotkey.com/docs/KeyList.htm 

Now you need to logout and login again to activate

example: press Shift then AltGr and release then click on "o c" to obtain ©

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.