Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Need help in getting the right mouse click to work on a HP mini 210-1015TU when using the touchpad.

If I plug in a USB mouse, both left click and right click function as normal. Using the touchpad however I can only get the left click to work. Attempting to right click gives the result expected from a left click. As per some comments on a forum I added a file 11-touchpad.conf to /usr/share/X11/xorg.conf.d. I can provide further details if required.

This made touchpad operation noticeably smoother but the problem with the right mouse click remains. Not a hardware problem as right clicked worked with 10.04 and still works with Windows 7 starter. 10.10 installed using wubi.

share|improve this question
    
It would help if you would describe a little more what works and what doesn't work. –  txwikinger Oct 15 '10 at 3:51
    
If I plug in a USB mouse, both left click and right click function as normal. Using the touchpad however I can only get the left click to work. Attempting to right click gives the result expected from a left click. As per some comments on a forum I added a file 11-touchpad.conf to /usr/share/X11/xorg.conf.d. I can provide further details if required. This made touchpad operation noticeably smoother but the problem with the right mouse click remains –  user4041 Oct 15 '10 at 5:12
    
Has the right button always worked until now? If you have never seen it work, maybe the button is physically broken. –  dgmdan Oct 16 '10 at 19:57
    
Yes, right mouse button worked on 10.04 and still works on Windows 7 starter (I installed 10.10 using Wubi) –  user4041 Oct 17 '10 at 9:45
    
possible duplicate of Touchpad not working on HP Pavilion dv6 –  Lekensteyn Apr 9 '11 at 16:25

4 Answers 4

You may also be interested in installing gpointing-device-settings Install gpointing-device-settings package, which will provide more configuration options for your touchpad.

Once installed you find it under System -> Preferences -> Pointing Devices.

share|improve this answer
    
Thanks. Will give it a try. –  user4041 Nov 17 '10 at 13:36
    
This worked a treat for me too - many thanks! (On a HP Mini 210-2001sa - fresh install of Netbook 10.10) –  user9406 Jan 23 '11 at 0:07

is that i'm going to input:

sudo su (Enter your password)

echo options psmouse proto=exps > /etc/modprobe.d/psmouse.modprobe
reboot

p/s: since i'm a newbie, i need to confirm the command to solve my problem at hp mini 210-1073TU.

share|improve this answer
    
That worked for me. –  user4041 Dec 5 '10 at 4:18
2  
@user4041 If this worked for you then accept it as the answer! –  Jorge Castro Jan 22 '11 at 18:52
    
Pretty awesome! Working fine as a solution for the HP Pavilion dm4. Solved my issue! Thank you! –  Geppettvs D'Constanzo Jul 29 '12 at 12:55
    
I own a hp elite-book 8530w. The modprobe.d fix didn't do it for me. Just led to mentioned lack of scrolling and sensibilty reduction. Anyone has an idea for me? –  con-f-use Aug 11 '12 at 11:08

try TAPPING the lower right corner of the touchpad instead of clicking the button

share|improve this answer
    
Occasionally this does work, but in most cases it responds as a left click. Thanks for the suggestion –  user4041 Oct 19 '10 at 20:47

I've found a workaround which worked with my Lenovo Edge E320 with a clickpad.

Just create /usr/share/X11/xorg.conf.d/51.clickpad.conf and paste the following content:

Section "InputClass" 

Identifier "Default clickpad buttons"
MatchDriver "synaptics" 
Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"

EndSection

After a restart of the xserver the clickpad worked just fine and the mulitouch features are now operational.

Source: Ubuntuusers.de

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.