Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a new user of linux environment. I'm using ubuntu 11.10 and a MTS Mblaze USB modem. I have installed it correctly and it was working good at first but when I restarted my system then I was unable to connect my Modem again. Whenever I want click on that MTS connection, a message prompts up "Modem Network Disconnected. You are now offline." Please help to get me out of this problem.

Thanks & Regards.

share|improve this question
add comment

4 Answers

A bug report is already created for this problem. It includes a work around also which may work for you. Check https://bugs.launchpad.net/bugs/868034.

share|improve this answer
add comment

check your modem manufacturer for example i have huwai E1550

make change to your "usb_modeswitch.conf" edit the file byyping this to terminal

sudo gedit /lib/udev/rules.d/40-usb_modeswitch.rules

to disable the rule place a # at start of the line , example

Quote:

# Huawei E1550
 ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1003", RUN+="usb_modeswitch '%b/%k'"

put a extra # in the front of line ATTRS(idVender)...........

# Huawei E1550
# ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1003", RUN+="usb_modeswitch '%b/%k'"

save this file and then restart

hope this will work because this worked for me . good luck

share|improve this answer
add comment

You can try this command from a terminal:

sudo killall modem-manager
share|improve this answer
add comment

The problem seems to be the network daemon's inability to detect the modem settings...aggravated by its lack of real time operability.You could just disconnect it, wait then reconnet it and IF THE NETWORK HAS BEEN RECOGNISED connect with no trouble at all.If not then you have to set up wvdial using appropriate settings to work(However,Doing so rendered network manager unable to recognize my connection and thus ALL applications were connected EXCEPT SOFTWARE CENTER which relied on identification by network daemon)SETTINGS FOR MTS INDIA; [Dialer cdma] Stupid Mode = 1 Inherits = Modem0 Password = mts Username = internet@internet.mtsindia.in Phone = #777

[Modem0] Init1 = ATZ SetVolume = 0 Modem = /dev/ttyUSB0 Baud = 115200 FlowControl = Hardware (CRTSCTS) Dial Command = ATDT

Just replace settings in wvdial conf file and then...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.