Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with fonts, appearance of GTK and KDE-based applications and cursors in Kubuntu 11.10 after upgrade from 11.04.

I want all of my applications, both GTK and KDE, under sudo and under my normal user, to look the same (using standard Oxygen theme and Arial font).

My usual way works only partially, here are the steps I usually do:

  1. Set up KDE widget style to Oxygen under my normal user (already set by Kubuntu installation), set up KDE UI fonts to Arial.
  2. Set up GTK widget style to oxygen-gtk under my normal user (already set by Kubuntu installation), set GTK fonts to be the same as KDE fonts.
  3. Set up GTK style for some non-KDE-aware GTK apps, using gtk-theme-switch2 and gtk-chtheme, to oxygen-gtk, set up UI font to Arial.

  4. Repeat steps 1-3 for widget style and fonts under kdesudo.

However, not all applications look in Oxygen and use Arial font after these steps after upgrading to Kubuntu 11.10 from 11.04.

Below are all screenshots I wanted to illustrate this question, merged into single image, due to askubuntu.com does not allow me to post more than one link or an image at the moment:

http://simplest-image-hosting.net/png-0-screenshots-merged

software-properties-gtk under sudo looks like the first picture from the link above (marked software-properties-gtk).

Strange, setting GTK wigdet style using gnome-control-center looks like second picture from the link above (marked gnome-control-center), there is no oxygen-gtk theme (could this fact be related to the problem?)

in KDM, cursor is Ubuntu default cursor (DMZ White), and not Oxygen (this happened after installing Gnome) - how can I change it?

in KDE applications under kdesudo, fonts remain Ubuntu and do not change after I set them to my typical Arial font I use for UI, screenshot is the last picture from the link above (marked kcmshell4 fonts).

Sometimes, in KDE applications under my ordinary user, fonts spontaneously change to Ubuntu font - why this happens and how can I avoid it?

Thanks.

share|improve this question

1 Answer 1

Different users can have different settings

The root /1/ has own settings. You could change the root's settings by starting the System Settings with the command:

kdesudo systemsettings

Root's gtk apps

As default the root's folder doesn't have the link to the oxygen-gtk.

To fix this you need to copy the hidden file .gtkrc-2.0-kde4 (note the dot !) from your home directory to the /root/ with name .gtkrc-2.0 (note the dot !) /2/, /3/.

Command line:

sudo cp .gtkrc-2.0-kde4 /root/.gtkrc-2.0

If you have the Root Actions Servicemenu /4/ installed you could use it to copy and rename.

System's default mouse theme (KDM cursor)

The Debian and the Debian based are using the alternatives /5/ to set the environmental variables.

:~$ man update-alternatives /6/
NAME
       update-alternatives - maintain symbolic links determining default commands

SYNOPSIS
       update-alternatives [options] command

DESCRIPTION
       update-alternatives  creates,  removes,  maintains  and  displays   
       information about the symbolic links comprising the Debian alternatives       
       system.

       It is possible for several programs fulfilling the same or similar functions 
       to be installed on a single system at the same  time.

To set the cursor theme with the alternatives command line:

sudo update-alternatives --config x-cursor-theme

With KDE gui:

Package: kalternatives /7/ - graphical alternatives system configuration tool

More: Change system default X11 cursor theme /8/.

Sometimes

Quote: "Sometimes, in KDE applications under my ordinary user, fonts spontaneously change to Ubuntu font - why this happens and how can I avoid it?"

Yes, I have noticed this. Why - beats me. The Kubuntu is resetting to the default Kubuntu settings (/usr/share/kubuntu-default-settings/kde4-profile/default/share/config/)

To fix this i have edited the Kubuntu defaults: /usr/share/kubuntu-default-settings/kde4-profile/default/share/config/kdeglobals.

Default Kubuntu kdeglobals has:

[General]
BrowserApplication[$e]=!rekonq
XftHintStyle=hintmedium
font=Ubuntu,9,-1,5,50,0,0,0,0,0
menuFont=Ubuntu,9,-1,5,50,0,0,0,0,0
desktopFont=Ubuntu,9,-1,5,50,0,0,0,0,0
toolBarFont=Ubuntu,8,-1,5,50,0,0,0,0,0
smallestReadableFont=Ubuntu,8,-1,5,50,0,0,0,0,0
taskbarFont=Ubuntu,9,-1,5,50,0,0,0,0,0

Looking my own kdeglobals: ~/.kde/share/config/kdeglobals and copying them to the defaults. Here:

[General]
BrowserApplication[$e]=!rekonq
XftHintStyle=hintmedium
font=Sans Serif,9,-1,5,50,0,0,0,0,0
menuFont=Sans Serif,9,-1,5,50,0,0,0,0,0
desktopFont=Sans Serif,9,-1,5,50,0,0,0,0,0
toolBarFont=Sans Serif,8,-1,5,50,0,0,0,0,0
smallestReadableFont=Sans Serif,8,-1,5,50,0,0,0,0,0
taskbarFont=Sans Serif,9,-1,5,50,0,0,0,0,0

Links:

  1. https://help.ubuntu.com/community/RootSudo
  2. http://forum.kde.org/viewtopic.php?f=63&t=62352
  3. http://kubuntuforums.net/forums/index.php?topic=3092288.msg201654#msg201654
  4. http://kde-apps.org/content/show.php/Root+Actions+Servicemenu?content=48411
  5. http://www.debian-administration.org/articles/91
  6. http://en.wikipedia.org/wiki/Man_page
  7. http://packages.ubuntu.com/oneiric/kalternatives
  8. http://kubuntuforums.net/forums/index.php?topic=3112235.0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.