Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I plug my external monitor through HDMI, I lose audio in my laptop. My external monitor doesn't have audio, so I want to keep the audio in the laptop's speakers. How can I do that?

share|improve this question
1  
We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Jorge Castro Oct 30 '11 at 18:07
    

Go to the sound menu at the top of the screen and click preferences. Alternatively, execute the command alsa-mixer. Under the output tab, see if there is an option in the dropdown for HDMI Output.

share|improve this answer
    
I couldn't make it work. This must be a hardware issue. – 719016 Feb 10 '12 at 11:24
    
Yep, guessing so. – William Feb 10 '12 at 13:42
    
This worked, I had HDMI selected as output, instead of the internal speaker. (And my HDMI monitor doesn't have speakers) – Lord Zsolt Apr 26 at 20:27

On the volume icon on the desktop, there should be an icon of the external HDMI device. Press that and you should be able to disable that device for sound and it will automatically use the built in sound of your laptop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.