Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a dual boot pc with windows and ubuntu 10.10. Ubuntu has underwent a fresh installation and now wireless connection is displayed as available but when i connect, it is unable to connect to internet.When i use a wired connection in ubuntu , i can access the internet and it works.The wireless connection works well when i use windows so i don't see a problem with wireless router also my lappy with ubuntu can connect to it .I'm using wired connection just for the time otherwise i use wireless.Some of the output which may be helpful fore reference.

lspci   
 o/p:

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev  01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0d.0 Communication controller: Conexant Systems, Inc. HSF 56k Data/Fax Modem
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
00:1f.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA   Display Adapter (rev 10)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)

 lshw -c network
 o/p:

 *-network               
   description: Ethernet interface
   product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: eth0
   version: 01
   serial: 00:1d:7d:56:84:51
   size: 100MB/s
   capacity: 100MB/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.1.7 latency=0 link=yes multicast=yes port=MII speed=100MB/s
        resources: irq:43 ioport:ec00(size=256) memory:febff000-febfffff memory:febc0000-febdffff
    *-network
        description: Wireless interface
        physical id: 1
        bus info: usb@1:4
        logical name: wlan0
        serial: 00:21:91:1d:f7:5c
        capabilities: ethernet physical wireless
        configuration: broadcast=yes driver=rt73usb driverversion=2.6.35-22-generic       firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg

    lsmod
    o/p: 

     Module                  Size  Used by
     aes_i586                7280  0 
     aes_generic            26875  1 aes_i586
     binfmt_misc             6599  1 
     snd_hda_codec_analog    59649  1 
     arc4                    1165  2 
     snd_hda_intel          22107  2 
     snd_hda_codec          87552  2 snd_hda_codec_analog,snd_hda_intel
     snd_hwdep               5040  1 snd_hda_codec
     snd_pcm                71475  2 snd_hda_intel,snd_hda_codec
     snd_seq_midi            4588  0 
     snd_rawmidi            17783  1 snd_seq_midi
     snd_seq_midi_event      6047  1 snd_seq_midi
     rt73usb                22442  0 
     crc_itu_t               1383  1 rt73usb
     rt2x00usb               9779  1 rt73usb
     snd_seq                47174  2 snd_seq_midi,snd_seq_midi_event
     rt2x00lib              27275  2 rt73usb,rt2x00usb
     led_class               2633  1 rt2x00lib
     mac80211              231541  2 rt2x00usb,rt2x00lib
     snd_timer              19067  2 snd_pcm,snd_seq
     snd_seq_device          5744  3 snd_seq_midi,snd_rawmidi,snd_seq
     ppdev                   5556  0 
     parport_pc             26058  1 
     cfg80211              144470  2 rt2x00lib,mac80211
     snd                    49006  13                     snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
     soundcore                880  1 snd
     sis_agp                 4123  1 
     snd_page_alloc          7120  2 snd_hda_intel,snd_pcm
     shpchp                 29886  0 
     agpgart                32011  1 sis_agp
     lp                      7342  0 
     parport                31492  3 ppdev,parport_pc,lp
     usbhid                 36882  0 
     hid                    67742  1 usbhid
     usb_storage            40172  0 
     r8169                  36489  0 
     sata_sis                3504  3 
     mii                     4425  1 r8169


     rfkill list wifi
     o/p:

    0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

EDIT:

http://www.computerandyou.net/2011/10/how-to-solve-no-wireless-network-detected-in-ubuntu-11-10/ Following the above link worked once but when i restart again i'm unable to connect to internet.

share|improve this question
add comment

2 Answers

While you are connected to wired network:

Open the terminal (Ctrl+Alt+T) and type the following command to install the Synaptic Package Manager:

sudo apt-get install synaptic

  1. Now open the Synaptic Package Manager and search bcm in it. Uninstall or remove any package if already (related to bcm) specially bcmwl-kernel-source

  2. Now install these two packages: b43-fwcutter and firmware-b43-installer.

Disconnect the wired network...restart.

Source: http://www.computerandyou.net/2011/10/how-to-solve-no-wireless-network-detected-in-ubuntu-11-10/

share|improve this answer
    
...it did't worked for me even though i followed the link referred.. –  GhostRider Oct 30 '11 at 14:44
    
see the edit and help.. –  GhostRider Oct 30 '11 at 15:55
add comment

Once you have followed the link which helped you (its another link on my blog only), then to make the changes permanent, follow these: Type the following command in the terminal

cat /etc/modprobe.d/* | egrep '8180|acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl' 

check if the term ‘blacklist bcm43xx‘ is present

if yes, then type cd /etc/modprobe.d/ and then sudo gedit blacklist.conf put a # in front of the line: blacklist bcm43xx then save the file (I was getting error messages in the terminal about not being able to save, but it actually did save properly). reboot

share|improve this answer
    
yes the same approach worked for me which i have also mentioned in you blog..i was connected to web and when i restarted my system ,i faced the same issue. blacklist bcm43xx is coming with a hash appended next time i check it –  GhostRider Oct 30 '11 at 18:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.