Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using the Ubuntu 10.10 with both VLC player and MPlayer and already installed the ATI drivers. I watched the same videos on Windows 7 and Ubuntu. But on Ubuntu the images have a lot of tearing. I tried some newbish-configs on my ATI config tool, but nothing changed.

I tried videos in mkv, avi, rmvb... and in all kinds of resolutions. I would love to see some tips or maybe a solution to this problem.

(I have searched for similar questions but I didn't find any :/ )

The english is not my primary lang so sorry for my mistakes.

Thanks in advance!

[]'s Leonardo

My HW Config (Acer Aspire 5740G-6979) -ATI Mobility Radeon 5650 -Intel Core i5-430M -4GB Ram

share|improve this question

5 Answers 5

up vote 6 down vote accepted

Tearing in videos is caused by the video drawing not being synchronised with the refresh-rate of the display. This results in displaying the top part of one frame and the bottom half on the previous frame at the same time, which is particularly noticeable on sections of video with horizontal panning.

The open-source drivers, with DRI2, should be able to synchronise their drawing with the screen refresh properly, even when running with desktop effects enabled¹. The proprietary nVidia and ATi drivers may not do this properly.

Finally, disabling desktop effects should eliminate the tearing regardless of what driver you're using - all (sensible) drivers can sync-to-vblank for video in this case.

¹: Technically, the problem is having a compositing manager running, because that means that all windows are first drawn off-screen and then composited to the display by the compositing manager. Since the video is first “drawn” offscreen, it's not possible to synchronise this to the screen refresh.

share|improve this answer
    
Ty RAOF for all the info. Just one more thing, do you know a good manager/program/app that I can use to easily/fastly enable and disable my compositing manager? (Once I used one that stayed on the traybar but I never found it again) –  Leonardo TM Oct 15 '10 at 5:37
    
This might be useful for switching effects on/off (I haven't used it myself). –  JanC Oct 15 '10 at 8:13
    
I dont have compiz and still i have tearing in ubuntu unity 2d, xubuntu,lubuntu,cinammon,mate,gnome shell everywhere ! And i tested many nvidia graphic cards the only way that i suceed to not have tearing is by using an ATI card and selecting the antitearing choice. –  digitalcrow Aug 21 '12 at 20:42

The easiest way to get rid of the tearing is to use the open source drivers (so, remove the closed source driver). Provided that your card works with them of course, but most cards do work (including 3D) with the open source drivers nowadays...

share|improve this answer
    
So I'll try some open source drivers. My VGA is an ATI 5650 (ACER AS-5740G), any specific tip or driver ? –  Leonardo TM Oct 15 '10 at 3:10
    
@Leonardo Please update your question with your hardware information so it doesn't get buried in the comments, thanks! –  Jorge Castro Oct 15 '10 at 3:34
    
The open source driver is named 'radeon', and it should be used by default if the closed source driver isn't installed. –  JanC Oct 15 '10 at 8:10

ATI has always been problematic for me in regards to video play when Compiz is active. In fact, I ended up dropping my beloved ATI's for nVidia because of it. But, I digress.

From a terminal run gstreamer-properties. Under the Video tab, try adjusting the Plugin for Default Output. You may lose some abilities to adjust size of viewing, but you may be able to fix most of the tearing.

In the past, I believed I used "X Window System (No Xv)", but I was not able to scale my videos in mplayer.

share|improve this answer

Try using xine media player, it uses very little resources. If you still have tearing or stuttering video try killing compiz temporarily.

share|improve this answer

There's no way to have tearing using an ati graphics card ! it has AntiTearing choice on control panel, ask me with my nvidia i have tearing when i dont use compiz , when i use compiz gaming sucks i have half of the fps and bad performance. I can say now that compiz and xorg sucks .... and some people believe that linux can reach the desktop pcs .... well dream on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.