Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Ubuntu alongside Windows 10.
I bought the machine with Windows 10 installed.
I want to install Ubuntu alongside Windows 10.
How to prepare the SSD before for Ubuntu ?

share|improve this question
up vote 3 down vote accepted

Boot into Windows - disable hibernation and Fast boot.
Open command prompt as administrator and execute :

powercfg /h off  

Open the old version of the Windows Control Panel.
Go to the Power Settings and uncheck Fast startup.
When it is not visible - enable show hidden settings.
Shutdown the machine completely, do NOT reboot.

Boot from Ubuntu installation media.
Select 'Try Ubuntu without installing'.

Open GParted ... to do this - just press the Windows key and type GParted.
Check whether there is free unallocated space on the disk, in case it's not :

Open GParted and shrink the Windows partition to generate free space.
Create a new partition - format it with ext4 - a size that fits your needs.
Create a new partition - format it with swap - a size matching the RAM.

On the desktop click Install Ubuntu - choose Something else.
Select the new partition you had created for Ubuntu before.
Select / as mount point and ext4 file system for formatting.

For boot loader location select the same disk where Windows is installed.
The boot loader will be automatically installed to the existing EFI partition.

Note :

I suggest to create a minimum of 20 GB space for the Ubuntu system.
In case you don't want to hibernate, you don't need the swap partition.
Assuming you have sufficient RAM, a swap partition is optional on a SSD.

Screenshots : example to demonstrate the setup and what GParted shows.

sda = HDD (personal data) | sdb = SSD (operating system) | sdc = USB (installation media)

enter image description here

enter image description here

enter image description here

share|improve this answer
    
Thanks for this. I tried Gparted but couldn't see except the USB volume!!!! – azyaser Feb 20 at 10:17
    
@azyaser What USB volume? You should not partition the USB volume you're installing from, partition your disk. – Avamander Feb 20 at 10:21
    
That is the thing, I can only see the USB of 7GB – azyaser Feb 20 at 10:25
1  
@azyaser : Choose UEFI - disable Secure Boot - select AHCI ... proceed as described in the instructions ... :) – cl-netbox Feb 23 at 10:55
1  
@azyaser : This is very strange and definitely a hardware related problem, maybe there have some other, additional settings in BIOS/UEFI to be made or something is wrong with the disk connection - otherwise I am running out of ideas ... :) – cl-netbox Mar 18 at 8:23

In addition to the steps outlined in cl-netbox's answer, which helped me through the installation process, I had to manually add the boot entry to the boot menu before I was able to open GRUB and continue booting after installation.

To do this, I followed these steps (see point 5, 6 & 7); open up the BIOS, go to Boot Sequence, click 'Add Boot Option' and using the file selector, pick the file shimx64.efi in 'EFI/ubuntu'. Move your newly created boot option to the top of the list.

Save and you should be able to select your newly added option. Press 'e' to update the Ubuntu option and add nouveau.modeset=0 after splash. This allowed me to finally boot in to Ubuntu 15.10.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.