Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to run a windows executable mounted through Archive Mounter.

I followed the directions of a previous answer, which was 'Open with ISO master, change permissions of the file(s), save the .iso, mount that .iso through Archive Mounter, then execute the file through the mounted .iso'

This didnt work. I spent well around 2 hours trying to get this to work, and im at my wits end now.

Is there ANY person out there that can offer a step by step solution to get my .iso file (and the .exe files therein) to work with Wine, mounted in Archive Mounter, without giving me the same annoying "CANT EXECUTE BECAUSE ITS AN .EXE FILE' nonsense?

The file im trying to run is an autorun.exe file for a video game. Im trying to install it on wine.

The operating system is Ubuntu 10.04

Im running on 10.04 Lucid Lynx.

share|improve this question
    
Why are you changing a ISO to execute a program with wine? How are you trying to run the exe file? –  Bruno Pereira Oct 29 '11 at 22:59
    
Perhaps it would be easier to provide a step by step answer if you provided a step by step explanation of what you did? It shouldn't be necessary to mark a Windows executable as executable in order to run it with wine. But many tools will assume it's a self-extracting zip-file, which will not work. –  Jo-Erlend Schinstad Oct 29 '11 at 23:02

1 Answer 1

Canonical put in an "interesting" feature in 10.04 which was intended to persuade "windows" users not to download random executables and run them. Perhaps understandable, but flawed, since it also prevented running executable from a read-only CD/ISO.

The capability is called the "cautious launcher".

There are a few ways to workaround this - you just need to be aware of the risks.

  1. Copy the executables to your desktop. Right click on the .exe file, select Properties, select the Permissions tab and check "Allow executing file as program". You should now be able to run the executable
  2. mount the cd/iso and run from the terminal wine /media/cd-name/windowsname.exe
  3. Right click on the .exe file, select Open with other application, followed by Use a custom command and use wine for the command. For executables in the future - right click the exe and then select Open with wine.
  4. remove the cautious-launcher permanently...

Edit the default launch command for wine

gksu gedit /usr/share/applications/wine.desktop

Change from

Exec=cautious-launcher %f wine start /unix

to

Exec=wine start /unix %f

source

share|improve this answer
    
I tried the first 3 options and it didnt disagree with me, however nothing happens. The autorun.exe program Im trying to run didnt even initalize, it started then disappeared. Any reason behind this? –  Erik Oct 29 '11 at 23:34
    
Look carefully at autorun.inf - it should indicate what executable it is actually trying to run. Run that exe. If it doesnt work, run that exe from the terminal - it should report errors if the executable cannot be run. Remember - not all windows applications run successfully in wine. Consult winehq.org for compability with wine. –  fossfreedom Oct 29 '11 at 23:40
    
Oh darn. Thank you very much for your help! –  Erik Oct 29 '11 at 23:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.