Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A fellow user came across a problem, and it's the exact same one that I'm having. I'm just reposting here to see if there's a faster response (original Ubuntu Forums post):

So I have upgraded to oneiric and I was excited to get gnome 3 and so i did and it's great, but in the applications menu many of the icons are showing double, which is strange. One will be clear and the next will be pixely. Also, this only happens when I'm in the "All" category, and with the Faenza icon set the pixely one is not in the Faenza style. I'm not quite sure how to fix this problem and I need some help.

A Google search turns up mostly closed Fedora-related bugs, so I'm not sure what I should do to try to fix this. Any help would be greatly appreciated!

share|improve this question
1  
Ok thanks! I'm not sure how but the duplicate icons are now gone. Maybe some update? I had already removed menu-xdg a while ago, and I'm not sure when the icons disappeared. –  cmontag Dec 8 '11 at 3:44

5 Answers 5

In the Activities Menu, search for the "Main Menu" app, then uncheck or delete the categories you see selected under Debian. This removed every instance of duplicate low-resolution icons for me.

Edit: I'd personally delete whole Debian icons tree - this will make sure those items aren't appearing even though you unchecked them, because I found this feature (disabling icons) buggy. Although there was problems which I stated a while ago, this was still solution of my problem.

share|improve this answer
    
Both this and abdallah's answer worked for me. –  Nalum Apr 30 '12 at 9:11
    
unchecking didn't work for me, had to delete, because the checkmark would appear again on its own. Probably some permission issues with gconf? –  pqnet Jun 3 '12 at 12:25
    
I did exactly as Lasbas has suggested in his post. I first unchecked Debian icons from Application Menu but for some reason they automatically get checked again so removed the checked options and it worked for me. Those pixel icons were too ugly. –  user161127 May 23 '13 at 11:20

I found the answer in different place, just remove 'menu-xdg' and it will work.

It worked on my laptop, i removed it then restarted and every thing is great now !!!

share|improve this answer
    
I did this and it didn't work for me. It reduced the number of icons but there's still some around (for example Banshee, Firefox, Deluge, etc still have two icons). –  cmontag Nov 4 '11 at 5:56
1  
it did work for me though. –  suli8 Nov 16 '11 at 21:04

Removing the 'Debian entries' (by opening 'Main Menu') worked for me. Interestingly, those duplicate icons were also the poor resolution ones. Everything looks much better now.

share|improve this answer

Go to - /usr/share/applications/ as root. Find .desktop files and delete them. But don't forget to make backup of those files.

share|improve this answer

It's a common result of, for instance, entering a single wrong character while using 'A lacarte' to install an icon.
.............................................................................

The file you we are looking for is...

x-[app-name].xml

...and the right folder is /usr/share/mime/application

cd there as su -, rm and reboot.

Note: Rename will have the same effect. You can delete it later anyway.

mv x-[app-name].xml x-[app-name].xml-backup

..................................................

Now check your default icons and workstation.

Doesn't hurt to run...

apt-get reinstall [app-name]

...to make sure that the defaults are reset.

..........................................................

I remove the application first, the x-[app].xml is my second step. Third, install it again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.