Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying this for a while but no luck. I installed ubuntu-11.10-desktop-i386 twice. Also installed guest additions. However I always get maximum screen resolution as, 1024 x 768.

Do I need to change anything in /etc/X11/xorg.conf file (example)? Presently there is no such file in that path. Also, would you be able to advise me what the contents of the file for 11.10 version should be?

share|improve this question
    
For 12.04 you need to run apt-get install virtualbox-guest-dkms after each kernel update. –  Thorbjørn Ravn Andersen Dec 10 '12 at 14:34
    
You'll need to install the VirtualBox Guest Additions. See How do I install Guest Additions in VirtualBox? –  gertvdijk Jun 25 '13 at 21:18
    
@ThorbjørnRavnAndersen worked fine thanks –  Zabs Mar 19 at 11:32
    
You need much more than merely guest additions installation. askubuntu.com/a/489948/287960 –  Gangnus Jun 30 at 11:33

15 Answers 15

up vote 56 down vote accepted

This worked for me and I am running VirtualBox 4.1.8 and Ubuntu 11.10.

sudo apt-get install virtualbox-guest-utils virtualbox-guest-x11 virtualbox-guest-dkms

Found it on this site under a slightly different question Higher screen resolution in VirtualBox?

share|improve this answer
1  
This worked for me. After installing the packages specified above and restarting VirtualBox the screen resolution in Ubuntu would adjust whenever I resized VirtualBox. –  shanewwarren May 7 '12 at 20:54
    
This worked for me too. I experienced the same thing with @shanewwarren –  mauris Sep 19 '12 at 14:42
    
same here. I also increased the video memory to 32 MB before that (may be unrelated). –  Rafael Reiter Mar 22 '13 at 21:28
2  
After doing this (and I saw it in other places too) with Ubuntu 12.04 guest, it stops booting –  Christian Vielma Sep 25 '13 at 15:52
1  
worked for me with ubuntu 14.04 on virtualbox 4.3.6 –  masterweily May 25 at 13:36

I was able to reproduce this issue repeatedly on Windows 7 host with Ubuntu 11.10 guest. Installing ubuntu from an iso image.

This issue happens when the either the Guest Additions are not installed or installed from ubuntu sources.

To fix this install guest additions from the virtual machine's Devices > Install Guest Additions option and running the autoprompt. If you already have the guest additions installed from a different source it will prompt you about removing the existing one and installing new guest additions, just say 'yes'. This will remove the guest additions if they are already installed from ubuntu sources and build from sources that came with your virtualBox installation.

This should fix the issue.

share|improve this answer
2  
+1: Fixed the problem perfectly with Windows 7 x64! –  Thomas Bratt Sep 7 '12 at 19:55
    
+1 This worked! –  stormwild Aug 28 '13 at 11:35
    
+1 worked for me on Windows 8 as well –  ashes999 Feb 28 at 2:24

I just installed Ubuntu 12.04 on VirtualBox 4.1.4, but couldn't get it to work on higher resolution, even after installing and reinstalling the VBOXAdditions. Desperate, I installed the VBOX 4.1.14 and reinstalled many times the VBOXAdditions, but without any success. Finally, the solution that solved the problem, was to increase the video memory (in VBOX setting for Ubuntu) from starting 12 MB, to 48 MB (which still did not enable resolution 1366x768), and than to 128 MB. After restarting Ubuntu everything works perfect, 1366x768 is my default resolution. I hope this will help in your problems. Cheers!

share|improve this answer
2  
Thanks. This did it for me as well. –  Martin Scharrer May 1 '12 at 9:10
    
Thanks. 48mb did the job! –  Mark Heckmann Jun 16 at 20:49

I was troubled with the screen resolution on Virtual Box on Windows 7 x64 as host and Ubuntu 12.04 LTS desktop as guest. I had raised the video memory to 128 MB, installed the VirtualBox Linux Additions, but it was still a no go. When checking the display setting in Ubuntu I could only choose between 800x640 (4:3) and 1024x768 (4:3).

Ticking the checkbox Enable 3D Acceleration in the virtual machine settings made it work. After that, when the guest window was resized, the size was reflected in the Ubuntu display settings. By turning on full screen mode I could use the full 1600x900 resolution in Ubuntu.

Hopes this might save someone's hair.

UPDATE: After enabling 3D acceleration Ubuntu became extremly sluggish. So I unticked the 3D acceleration and I could still enjoy full screen resolution.

share|improve this answer
    
I tried a fair number of suggestions but this one finally gave me full 1600x900 resolution. Thanks :-) –  Elliveny Jan 14 at 9:56
    
This did it for me, too! –  David Oneill Apr 4 at 15:14

This is likely a VirtualBox issue, rather than an Ubuntu issue.

I have had the same problem repeatedly before. Sometimes removing and re-installing the Additions solves this. Or simply forcing VirtualBox to actually load them, and not just download them.

Unfortunately, this issue recurs. I have found that updating VirtualBox (to a newer build) sometimes makes this worse AND sometimes solves this. This is a recurring issue ..

share|improve this answer

My system is 64bit Windows 7 SP 1 running Ubuntu 12.04 LTS 32 bit (i386). I had to do almost everything for it to work. To summarise:

  1. With the virtual machine shutdown, change the 'Settings' of the pertinent virtual machine. Under 'Display' -> 'Video' move the video memory slider to '128mb' and also tick 'Enable 3D Acceleration'.

  2. Now load up your Ubuntu virtual machine. Under 'Devices' click on 'Insert Guest Additions CD Image'. Wait for it to do its thing.

  3. Restart the virtual machine. You should now be able to achieve the higher resolutions. If not, it may be because the virtual machine's window isn't large enough. Drag the corner to make it larger or simply do: 'View'->'Switch to Fullscreen'

Hope this helps someone. Thanks to all the other answers for helping me out.

share|improve this answer

Entering the game lately, not sure this answer will help, but having a similar resolution issue (Mac host, Ubuntu as vbox), and after playing with xrandr, xorg.conf etc... I tried the following

  • close Virtual Box
  • enter the host terminal command VBoxManage setextradata Linux CustomVideoMode1 1152x680x32 where Linux is the vbox name, CustomVideoMode1 is a name you give with 1 for one new resolution, 1152x680x32 for a 1152 x 680 x 32 bits colors resolution (VBoxManage.exe on Windows)
  • start your vbox
  • re-install the Guest additions

worked immediately after a vbox reboot.

more info

share|improve this answer

Had problem with screen not full size after updates. Running Ubuntu 12.04. In the VBOXADDITIONS media I simply ran the autorun.sh - this uninstalled and reinstalled guest additions and then I rebooted and everything was back to normal.

share|improve this answer
    
The reason for losing the guest additions after updates is because you haven't installed the dkms package prior to installing them. DKMS will take care of rebuilding the kernel modules when you install updates. –  gertvdijk Jun 27 '13 at 7:22

With Ubuntu 12.04 as host and guest I followed wfudge answer.

This requires other packages to be installed:

sudo apt-get xserver-xorg-core

After that, executed this modified line from wfudge hinted by apt-get:

sudo apt-get install virtualbox-ose-guest-utils virtualbox-ose-guest-x11 virtualbox-ose-guest-dkms virtualbox-guest-x11

After that Ubuntu guest didn't boot into GUI, so with Ctrl+Alt+F1, logged in a console and executed:

sudo apt-get install ubuntu-desktop

Reboot and done. Now I can get higher resolutions up to 1600x1200. Still not 1920x1080 (host), so it's not full screen, but at least is much better than what I had before.

I guess is a VirtualBox problem, but when used a Windows host didn't have this problem...

share|improve this answer

Using VirtualBox 4.3 on Windows 8 and guest Ubuntu 12.04

I installed virtualbox guest additions from the iso file provided in the virtualbox install directory (used autorun.sh) + restart guest.

I first thought it didn't work: the resolution was still low and screen parameters didn't show any higher resolution

Then I realised the guest screen was in "scale mode" (host+c), I switched to full screen (host+F) and resolution was fine!

share|improve this answer

I have same problem on my notebook DELL M6600 with Ubuntu 12.10. I had to install quest additions in windows safe mode. After that, desktop screen resolution was done by size of the window with guest OS.

share|improve this answer

Just run ubuntu on virtual machine and install "VirtualBox Guest Additions" (Devices -> Install Guest Additions). After the installation reboot your guest system.

Now resolution will change automaticaly depending on window size.

*I use Ubuntu 13.04 on VirtualBox 4.2.12 for Mac OS

Good luck.

share|improve this answer

Sometimes it is very simple (refering to 12.03/4) On the virtual machine window, hit the maximize button and it will fill screen, and cause Ubuntu to re-detect the screen resolution from the VM.

Else, Christian Vielma's answer, doing all three steps one after the other, will enable this option.

share|improve this answer
  1. Close VirtualBox.

  2. Paste this on Host Terminal:

    sudo VBoxManage setextradata NAME CustomVideoMode1 1152x680x32
    

    where NAME can be found in SettingsGeneralBasicName.

  3. Restart VirtualBox.

share|improve this answer

Using plain X11 without a heavy desktop client, ratpoison in my case, the following package is all that is needed:

virtualbox-guest-x11

I understand other packages might make your kernel aware that it is running in a virtual environment for some benefits, but this package seems to handle the resolution issues.

share|improve this answer

protected by Avinash Raj May 14 at 14:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.