Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I select Radiance or Ambiance in the menu show in the following picture, my whole theme does not change. It only changes the title bar.

Screenshot

How can I resolve this problem? Or how can I reset the theme to default?

share|improve this question
    
What happens when you try to change the theme with the ubuntu-tweak-tool? –  joschi Oct 30 '11 at 10:10
    
I tried it. But nothing happens. I cannot see a change in the GUI. –  Strubbl Oct 30 '11 at 11:01
    
I have this problem, too. It occurred after running a modified version of unity-greeter thus: unity-greeter --test-mode –  Scott Severance Oct 31 '11 at 7:13
    
This is related to lightdm, apparently. –  Scott Severance Oct 31 '11 at 7:18
1  
@Matthew Possibly. We'll see what tachyons says. –  jrg Apr 3 '12 at 14:52
show 4 more comments

8 Answers 8

I had the same issue in Ubuntu 13.04. I just installed the gnome-tweak-tool Install gnome-tweak-tool and changed the current theme under theme menu. It solved this.

share|improve this answer
add comment

I faced the same problem. After lots of search I came to know that gtk 3.4.2 was the root of the problem. I installed it for my programming purposes. Even the above solutions were not working in my system. So I just uninstalled it and it started working just fine.

share|improve this answer
    
Welcome to askubuntu ,Don't ask question in answer section ,please post it separatly including link to this question :) –  Tachyons May 6 '12 at 11:28
add comment

Basically, here's what happened:

When you ran Unity Greeter, it started to really freak out, because its not supposed to be run as a normal user (although it is possible, I'll get into that in a moment).

To fix it, you need to go into dconf-editor (install the dconf-tools package), and then head to Org > gnome > settings-daemon > plugins, and then make sure that everything is enabled.

Log out and back in and you should be good to go!

To run Unity Greeter/lightDM in a window so you can take screenshots, run

unity-greeter --test-mode

or

lightdm --test-mode
share|improve this answer
    
oh thanks i enabled Org > gnome > settings-daemon > plugins >xsettings ->active now it works :) without any logout –  Tachyons Apr 3 '12 at 14:54
add comment

I had the same problem after I ran unity-greeter in the terminal. From that moment on my theme did not load completely anymore. Only the title bar could be changed by selecting another theme.

Deleting config files, logging out, dconf-editor settings and so on did not work for me.

What solved the problem was to run /usr/bin/gnome-settings-daemon in the terminal. All settings were instantly in place.

So, I added it to the 'startup items' and the problem was solved. Everything works fine now.

share|improve this answer
add comment

Try running:

    gksudo gedit /etc/xdg/autostart/gnome-settings-daemon.desktop

and then replacing the line:

    Exec=/usr/lib/gnome-settings-daemon/gnome-settings-daemon

with:

    Exec=bash -c "sleep 5; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"

You might need to increase the sleep number. I got this from webupd8.

share|improve this answer
add comment

Install dconf-editor if you don't have it, and then go to

org.gnome.settings-daemon.plugins.xsettings

and check "active." One thing I've also noticed when this happens is that the media keys stop working: enable org.gnome.settings-daemon.plugins.media keys. There also might be some more plugins you should enable.

Problem cause: when unity-greeter is run (by the lightdm --test-mode command in my case), it disables a lot of settings-daemon plugins that have to be manually reenabled.

I got all of my info from this thread: http://ubuntuforums.org/showthread.php?t=1861476

share|improve this answer
    
A great answer! Helped me with a similar issue on 12.04 and finally I've got my media keys back! Very comprehensive. –  savick01 Jul 25 '13 at 23:50
add comment
up vote 3 down vote accepted

Removing the file ~/.config/dconf/user solves the problem.

PS: To reconstruct the problem I made the following steps: change in the file /etc/lightdm/unity-greeter.conf the line

font-name=Ubuntu 11

to

font-name=Ubuntu 10

and after saving run the command

lightdm --test-mode 

That was all I modified yesterday. Now if you restart your session with CTRL+ALT+BACKSPACE and login again, your theme is ugly (like mine on the screen shot in my question). Can anyone verify this?

share|improve this answer
    
-1. Removing ~/.config might solve this particular problem, but it'll cause others (most user settings will be lost). So, it's an unacceptable solution. –  Scott Severance Oct 31 '11 at 7:16
    
That's the way I didn't accept this as "the solution" for this question. So what's an acceptable solution, Scott Severance? –  Strubbl Nov 1 '11 at 9:55
    
I wish I knew. I'm experiencing the same problem, for the same basic reason. I haven't found a solution, and am unwilling to delete ~/.config –  Scott Severance Nov 2 '11 at 0:36
    
Then perhaps you should backup your ~/.config and delete every file in there step by step, so you find the files which are causing this bug. –  Strubbl Nov 2 '11 at 20:48
1  
@ScottSeverance I refined/edited my solution. Only remove ~/.config/dconf/user. Then many settings like Desktop background and so on are gone, too. But this is more fine than removing the whole ~/.config folder. –  Strubbl Nov 4 '11 at 17:45
show 4 more comments

Have you tried logging out/logging back in? Typically on my install the theme switch does not complete until I do this.

It is curious that some of your desktop seems to revert back to the default GNOME theme, though.

Also, if this does not work, you may also want to try a reboot.

share|improve this answer
    
Yes, I have tried login/logout. Several times. I was so distressed, that I rebooted. –  Strubbl Oct 29 '11 at 19:43
    
@Strubbl That's all I can think of. Sorry if I was unable to help. –  WarriorIng64 Oct 29 '11 at 19:49
    
No problem. I am not giving up and keep this thread up to my latest insights. –  Strubbl Oct 29 '11 at 20:10
    
Logging out doesn't work. Rebooting doesn't work. –  Scott Severance Oct 31 '11 at 7:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.