Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm working on a Qt application that uses Phonon and has CMake as it's build system. When I try to configure the application I get the following configure output:

-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
  Could NOT find Qt4 (missing: QT_PHONON_LIBRARY) (found suitable version
  "4.7.4", required is "4.4.3")
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-2.8/Modules/FindQt4.cmake:1162 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:21 (FIND_PACKAGE)

I know my CMakeLists.txt isn't the problem because it works fine on other machines. Also, I have libphonon-dev installed. Anyone know what the problem is? I feel like I may not have the right phonon package installed. There are so many different ones in the repository. Which one is the correct one?

share|improve this question
add comment

2 Answers 2

Well, I guess for what ever reasons CMake just didn't want to find libphonon.so which I determined was located in /usr/lib/. So after manually setting QT_PHONON_LIBRARY_RELEASE to /usr/lib/libphonon.so everything worked.

share|improve this answer
add comment

Did you put this in your CMakeLists.txt file?

SET( QT_USE_PHONON TRUE )
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.