Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Im having problems applying a new icon theme in ubuntu 11.10 specifically with the power icon. Ive installed faenza succesfully, and the gnome tweak tool to change the icons, but the power icon doesnt seem to be updating:

Incorrect power icon

No matter what i change the icon theme to now, i cant seem to get the power icon to return to the default one, let alone the faenza one. Any suggestions where im going wrong?

share|improve this question
    
Does this problem remain after restart or logging out? In my experience, the power manager indicator has to be restarted to apply the new icon theme. –  jnv Oct 29 '11 at 16:49
    
Yea ive tried restarting a couple of times, doesnt seem to make any difference –  richzilla Oct 29 '11 at 16:51
add comment

2 Answers 2

up vote 5 down vote accepted

I had this problem too. I prefer the Faenza-Dark variant but has a rubbish battery icon like in your screenshot. If you used the ppa to install the icons then you should have a Faenza-Ambiance/Radiance theme to choose which fixes it, but as I prefer the -Dark variant I had to make a custom version. What I did was copied Faenza-Dark to another folder like Faenza-Custom sudo cp -r /usr/share/icons/Faenza-Dark /usr/share/icons/Faenza-Custom
Then edit it. sudo nano /usr/share/icons/Faenza-Custom/index.theme delete everything in it and paste in this

[Icon Theme]  
Name=Faenza-Custom  
Inherits=Faenza  
Comment=Icon theme project with tilish style, by Tiheum

Directories=status/22,stock/22  

[status/22]  
Size=22  
Context=Status  
Type=Fixed  

[stock/22]  
Size=22  
Context=stock  
Type=Fixed  

then use gnome-tweak-tool to choose the Faenza-Custom theme and it will have the fixed battery icon

share|improve this answer
    
duffydack, thanks a lot for the tip, that worked for me, however the notification bubble that comes up once in a while when the battery is discharging, the same old (ugly) icon is still there... anything I can do about that? thanks –  Valeriu Oct 29 '11 at 22:45
    
Thanks for this (I prefer the Dark variant too). There's one problem, I think: shouldn't it be "Inherits=Faenza-Dark"? –  Aibara Iduas Oct 29 '11 at 23:09
    
Faenza is where most of the variants inherit from. All I know is, it works. –  duffydack Oct 30 '11 at 11:22
    
I just unplugged mine and never got any bubble. hmm. did you make the custom icon folder 755? sudo chmod -R 755 /usr/share/icons/Faenza-Custom –  duffydack Oct 30 '11 at 11:25
    
edit just did it again and had the notification, all looks fine. i.imgur.com/dxymI.png –  duffydack Oct 30 '11 at 11:33
show 2 more comments

I had this problem too using Radiance theme, but I fixed it replazing the folder icons from /usr/share/Faenza-Radiance/status/22 with /usr/share/icons/ubuntu-mono-light/status/22

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.