Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

after upgrading my ubuntu to 11.10, my internet connexion became SO slow or it goes away for a couple of seconds.

It is a wireless connection, I have a dell studio 1525 and I have not install any additional driver

I know that it is a general question, but I really have not any more information.

Thanks

share|improve this question
    
Could you please provide some more details? what kind or connection, wired or wireless? what's your computer's make and model? did you install any additional drivers? if so, which ones? –  roadmr Oct 29 '11 at 15:38
    
thanks for your answer. it is a wireless connection, I have a dell studio 1525 and I have not install any additional driver –  Alejandro Oct 29 '11 at 15:56
    
Add All information in the question! the comments are to improve the question not for a discussion! :) –  Alvar Oct 29 '11 at 16:17
    
We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro Oct 29 '11 at 22:29

3 Answers 3

up vote 3 down vote accepted

Same issue here with network controller: Intel Corporation WiFi Link 5100 Everything was working perfectly with previous versions of Ubuntu but after updating from Natty 11.04 to Oneiric 11.10 the problems with N-Channel started.

The following commands solved the problem.

sudo rmmod iwlagn
sudo modprobe iwlagn 11n_disable=1

Try browsing again and if there is an improvement, make this change permanent by creating an 'options' file:

gksu gedit /etc/modprobe.d/options.conf
and add the line

options iwlagn 11n_disable=1

Hope this will help.

share|improve this answer
1  
AWESOME!!!!!! I don't know what I am doing with this commands but now it works pretty well.. THANK YOU!!!! –  Alejandro Nov 8 '11 at 2:45
    
I tried so many things!! but this worked perfectly. I still dont understand the problem: wifi worked fine in my laptop for windows and for ubuntu everywhere except in my parents house where their wifi connection didnt work only in my ubuntu but it did work in my windows and in everyones else's computers –  fersarr Dec 21 '12 at 5:33
  • First of all you need to check physically you wireless card ; by making connecting to your wireless network, if this succeed then ping to the localhost 127.0.0.1 if there no packet missing, then make ping to default gateway that is usually ends in .1 for example 10.0.0.1 (X.X.X.1 or X.X.X.255) if you test all this meas that your WNIC is is working well!
  • The second think that you should do is test your Internet services provider by entering to this web page: http://speedtest.net/ if your speed test don't agrees whit your ISP speed then you should call your ISP for technicals assistances

try to test it in Windows if this still happen my only conclusion is that you have a problem whit your ISP

share|improve this answer
    
when I connect physically to the router, it works well. I ping to localhost and default gateway and I had some packets lose. In another pc that I have, with windows, I had no problem at all. :( –  Alejandro Oct 29 '11 at 20:06

I had a similar issue, this link seems to be the fix! http://www.unixmen.com/linux-tutorials/linux-distributions/linux-distributions4-ubuntu/1785-resolve-slow-connexion-when-using-wifi-in-ubuntu-1104-natty-narwhal

share|improve this answer
    
thanks for your answer, but I tried with this link and nothing happen with my wireless connection :( –  Alejandro Nov 1 '11 at 3:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.