Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Gnome Shell 3.2 on Ubuntu 11.10.

I have installed Hamster Applet package version 2.32.1-0ubuntu5. There is now a Time Tracker application. Clicking on it does start the application where I can enter data, etc. But there is no indicator either in the top bar or at the bottom notification area. There are no periodical reminders.

Is there something missing? How do I get the features it had with Gnome 2.3

Thanks in advance.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Use a Shell extension, it can be downloaded through Gnome's official site: https://extensions.gnome.org/extension/425/project-hamster-extension/

(Thanks to @tm_lv for heads-up)

EDIT: Installing the extension locally using gnome-tweak-tool apparently crashes Shell. The extension must be installed using waf as described in README, however it's not that easy. You need a few packages to build the extension

sudo apt-get install gettext intltool

Now download the source using git or https://github.com/tbaugis/hamster-shell-extension/downloads

Once you clone/unpack the source, go into the created directory and execute

./waf configure --prefix=/usr
sudo ./waf install

This will install the extension into /usr/share/gnome-shell/extensions/hamster@gnome.org directory.

The extension will appear in gnome-tweak-tool in Extensions section once you restart Gnome Shell.

To uninstall the extension, execute this from the source directory:

sudo ./waf uninstall

Note that this extension doesn't play well with the older version of Hamster available in Ubuntu repository, more details are in this bug report. You better build the newest version of Hamster yourself, as described on Hamster's site. Remember to uninstall hamster-applet first and install dependencies for "Debian-based" system.

share|improve this answer
    
Well - I downloaded the zipfile, opened Advanced Settings and added the shell extension. It says added successfully - restart. After logging out and logging in, there is no top bar. I had to delete .local/share/gnome-shell and .local/share/hamster-applet to get the bar back. Am I missing something? What is the remedy? –  deshmukh Oct 29 '11 at 18:13
    
Have you followed the README? The recommended way to install is using the bundled waf –  jnv Oct 29 '11 at 19:23
    
The README has a sudo command that I do not understand. How do I UNDO if things get messed up? Better still, how do I 'uninstall' when the extension is available as a package? –  deshmukh Oct 30 '11 at 11:11
    
Those are fair concerns. I've attempted to install extension myself and it seems that local installation (using gnome-tweak-tool) crashes the Shell. Also it doesn't work well with the Ubuntu's version of Hamster - I've edited my answer to address these issues. sudo basically executes the command as root, allowing you to do system-wide changes. See e.g. man sudo or pcworld.com/businesscenter/article/230695/… –  jnv Oct 30 '11 at 16:02
1  
link update: github.com/projecthamster/shell-extension also the extension is now online at extensions.gnome.org: extensions.gnome.org/extension/425/project-hamster-extension –  tm_lv Oct 6 '12 at 20:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.