Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I turned my 16 GB USB stick into LiveUSB for Kali with dd. After I was done, I wanted to format it into NTFS for watching movies, however something went bad and it is broken now. It just says ISOIMAGE as name. It can't be mounted and when I try to format it again I get the warning:

enter image description here

What am I supposed to do. Can it be rescued?

Edit: I have created the Liveboot and tried to format the USB both within Ubuntu. The problem is related to ubuntu and I don't agree that it is off-topic.

share|improve this question

closed as off-topic by Pilot6, user68186, Fabby, Eric Carvalho, David Foerster Feb 17 at 9:53

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Fabby, Eric Carvalho
  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Pilot6, user68186
If this question can be reworded to fit the rules in the help center, please edit the question.

    
You need to replace the flash drive. – Pilot6 Feb 15 at 10:17
    
@Pilot6 Can you explain please? Like, is it trash now? – SarpSTA Feb 15 at 10:18
4  
flash drivers are not very reliable, if used this way. It probably is dead. – Pilot6 Feb 15 at 10:19
    
May I ask a (for some people) rude question: How much did your flash drive cost? – tim687 Feb 15 at 13:33
1  
@SarpSTA I think that you really need to replace your USB drive at this point :-P. It it completely dead – tim687 Feb 15 at 18:28
up vote 11 down vote accepted

I have been able to solve the problem.

I have tried to format it on Windows too but the problem persisted. Same thing with gparted and Disks too.

So I did the following:

sudo -i
fdisk /dev/sdx (in my case was sda)
n
-set attributes as default-
w

After that, went to gparted and reformatted as ntfs. And bingo!

share|improve this answer
11  
Be very, very, very careful to use the correct device here. Might be better to use one of the /dev/disk/by-id/* symlinks instead of /dev/sdx directly; much less risk of getting it wrong without noticing. – Michael Kjörling Feb 15 at 13:09
2  
Any explanation about what this actually does? – Zaibis Feb 15 at 14:04
    
n = new partition; w = write partition table and exit – Cees Timmerman Feb 15 at 14:39
    
Well, at least /dev/sdx doesn't point to any drive, so if a careless user just copy and paste they won't mess up their system. – Nighto Feb 15 at 20:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.