Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Pinnacle PCTV HD PCI card . I am able to view and hear ATSC/QAM channels with this card using Kaffeine.

I can also view all of the analog channels. The problem is that there is no sound in tvtime.

Here's my card info:

05:05.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
 Subsystem: Pinnacle Systems Inc. Device 0051
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64 (5000ns min, 13750ns max), Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 20
 Region 0: Memory at f9000000 (32-bit, non-prefetchable) [size=16M]
 Capabilities: <access denied>
 Kernel driver in use: cx8800
 Kernel modules: cx8800

05:05.1 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)
 Subsystem: Pinnacle Systems Inc. Device 0051
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64 (1000ns min, 63750ns max), Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 20
 Region 0: Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
 Capabilities: <access denied>
 Kernel driver in use: cx88_audio
 Kernel modules: cx88-alsa

05:05.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
 Subsystem: Pinnacle Systems Inc. Device 0051
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64 (1500ns min, 22000ns max), Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 20
 Region 0: Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
     Capabilities: <access denied>
 Kernel driver in use: cx88-mpeg driver manager
 Kernel modules: cx8802

If I do this:

"arecord -D hw:1,0 -f dat | aplay"

I get sound but the volume control in tvtime doesn't work. I can however adjust the volume with the alsa-plugin device in pulseaudio.

What I want is for tvtime to work as it should.

Thanks

share|improve this question

3 Answers 3

It seems like tvtime hasn't kept up with the times and does not use ALSA or PulseAudio, and instead tries to use OSS, which is likely disabled. You can attempt to have PulseAudio redirect OSS requests for this application by running it under padsp:

sudo apt-get install pulseaudio-utils
padsp tvtime

If that doesn't work, try the suggestions that use sox as well, mentioned here: http://ubuntu-ky.ubuntuforums.org/showthread.php?p=6350938

share|improve this answer

Did you try to install gnome-alsamixer, and adjust the tvtime sound from this ?

share|improve this answer

I don't know if this is too late but if yet useful:

I suggest you to give a chance to this command in a terminal, which may result in some audio being gathered from the proper device (/dev/video?) and routed to the sound output. Additionally you may need to change your /dev/video? for the proper one.

tvtime option --device /dev/video1 | arecord -D hw:1,0 -r 32000 -c 2 -f S16_LE | aplay -

Somehow, redirecting the tvtime to the proper device (/dev/video?) will result in the audio also being redirected from/to the right way.

In order to know which devices you can use you may wish to use this command:

ls -l /dev/video*

Which will result in a list like this:

geppettvs@DYLAN:~$ ls -l /dev/video*
crw-rw----+ 1 root video 81, 0 2012-04-21 09:58 /dev/video0
crw-rw----+ 1 root video 81, 1 2012-04-21 09:59 /dev/video1
geppettvs@DYLAN:~$ 

so you will know which devices are available to be used by tvtime (or other software).

I hope this help you or somebody else.

Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.