Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a new user and can't have my Huawei E1550 dongle installed & connect to the internet. Can anyone help?

Using Ubuntu 11.10

share|improve this question

3 Answers 3

Mode-switching – method one Thanks to OdyX (who maintains usb-modeswitch) this is the simplest method. Open a terminal (Applications->Accessories->Terminal) and type:

sudo apt-get install usb-modeswitch usb-modeswitch-data

Mode-switching – method two On inserting the device, if you open a terminal (Applications->Accessories->Terminal) and type dmesg you’ll see something like this:

[IMG]

The device has a small amount of storage space and identifies itself (on Windows) as a mass storage device, installs the driver and away you go. The problem is Ubuntu does what it is told to, it thinks its a mass storage device. The switch is never made in software because the software isn’t for Linux. We need to manually switch it using a little program that has been installed by default for a while now – “modem-modeswitch”. You need to pass it some parameters but we want the system to do this automatically when we insert the device – so we will configure a udev rule instead. Open a new file to store the rule by typing gksu gedit /etc/udev/rules.d/15-huawei-e1550.rules and paste in the following code:

SUBSYSTEM=="usb",SYSFS{idProduct}=="1446",SYSFS{idVendor}=="12d1",RUN+="/lib
/udev/modem-modeswitch --vendor 0x12d1 --product 0x1446 --type option-zerocd"

Save the file and close the editor. Remove and re-insert the device. You should notice that service providers icon has popped up on the desktop – don’t worry about it as it is just the storage part of the device being recognized. Configuring the connection If you now click on the network-manager icon in the notification area, you’ll see a new option, “New Mobile Broadband (GSM) connection”

share|improve this answer
    
I dont see img but IMG tag in your answer. @fredymusyadat can you edit the answer,please? –  Kamal Reddy Jan 10 at 18:16
    
finally able to use huawei dongle on ubuntu. Thank You. –  Kamal Reddy Jan 10 at 18:30

To Solve your problem, I have two options, both are working the same. Whichever you like install it. It's easy to configure and use.

You can find the details as bellow.

1 ]

GNOME PPP is an easy to use graphical dialup connection configuring and dialing tool with system tray icon support.

It uses GNOME/GTK+ for its graphical interface and integrates well in GNOME desktop environment, but it can be used in other environments.

It also uses WvDial dialer as its backend, providing simple configuration via config files. You can also use plain wvdial if you don't have X running.

Homepage: http://www.gnome-ppp.org/

2]

KPPP is a modem dialer for connecting to a dial-up Internet Service Provider. It displays statistics and accounting information to help users keep track of connection costs.

This package is part of the KDE 4 networking module.

You can find both Apppication on Ubuntu Software Center. both have Graphical Environment. So, you can easily configure and dial-up

share|improve this answer
    
Thanks for the answer & details :) the E1550 dongle is a 3G modem (SIM) not a dial up. Any idea how to install it? i.e. driver? –  NewwUserr Oct 30 '11 at 16:40
    
i had done the same way.remember WVdial it has all usb modem driver –  Deepak Rajput Oct 31 '11 at 4:06

Adding the udev rules does not make the dongle persistent in 11.10.

It is often necessary to restart the machine to get the device to register; either that or delete the entry in the network manager, re-insert the modem and re-register a new connection in the network manager, every time it's needed, just like in Ubuntu 9.04.

The suggested method works fine in 10.04, so it's bad inconsistency for it to be failing 3 versions later.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.