Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm unable to find a setting to change the default music app in Ubuntu's dash home. When I uninstalled banshee the default music app changed to Mplayer.The problem is that when I press my media key(on the keyboard) to start a media player it starts Mplayer rather than Amarok.

When i uninstall all media apps except Amarok it changes to default and all keyboard media buttons work perfectly with it,but as soon as i install another media app the new one displaces Amarok.

Ubuntu 11.10

share|improve this question

2 Answers 2

At your top extreme end of your screen,click on power icon and select 'System settings'. At 'System Setting' select System Info and move to 'Default Applications' and click on the drop-down menu and select AmaroK among others players under 'Music'. There are lots of other applications you can set to default in that place.

NB: Should in case you couldn't find Amarok among the list in your System Setting; then you have to install it.

share|improve this answer
    
Strangely i dont have Default Applications in system settings menu –  NewguyXD Oct 28 '11 at 19:11
    
Found it in "System settings">"System Info">"Default Applications" -pretty sure that what you meant too...thanks mate! –  NewguyXD Oct 28 '11 at 19:13
    
Yes! That was what I meant. Little multitasking and I missed to add System Info. –  all4naija Oct 28 '11 at 19:29
    
Confirm. Ubuntu 13.04 too Ubuntu 13.10 too –  Vitaly Fadeev Oct 20 '13 at 4:29

I have been trying to connect ubuntu's (gnome) multimedia shortcuts to amarok.

It makes sense that only one app is governed by such keypress events, and that the application selected is the default one. So I even tried uninstalling Rhythmbox. (After failed attempts on global shortcut modifications from both Ubuntu settings and Amarok settings). I even installed a Multimedia Keys script to Amarok. Nada!

Solution was inspired by command console control of Amarok:

From the keyboard shortcuts settings of Ubuntu (or any other flavor of linux), create a custom global shortcut and enter the command that does the job you want. (Eg. amarok --next, in your case just: amarok to initiate it maybe?)

Then accross the shortcut you will see disabled. Click on it and it switches to listening mode. Then press the key (or key combination) you want. It will probably warn you that the key is already assigned. But you can choose reassign and you are done!

share|improve this answer
    
You write quite a long story before you get to the point. It would be helpful for your readers to somehow highlight the solution or move the introduction behind the solution. –  David Foerster Oct 29 at 11:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.