Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running version 11.10 on a VirtualBox VM with ~1000MB dedicated memory, on mid-range hardware and using Windows Vista as a host. It came with Unity pre-installed. I ran:

apt-get install gnome-shell

When it was complete, I logged out from Unity, clicked on the Gear icon to select my UI and noticed that there was no trace of Gnome Shell:

The only available options

I tried selecting GNOME thinking that it could be the right one but I was presented with this desktop, which I don't believe to be the Gnome Shell Desktop:

The desktop I was presented with

Am I doing anything wrong?

share|improve this question
2  
This looks like it's hitting the fallback mode, check to see if your hardware acceleration is set up in VB? –  Jorge Castro Oct 28 '11 at 18:28
1  
Specifically, make sure you have 3D acceleration turned on. Without it, I can't run GNOME Shell. It seems 2D acceleration doesn't matter as much here. –  Kris Harper Oct 28 '11 at 18:36
    
I enabled it, restarted the machine and it still does not work. –  Gabriele Cirulli Oct 28 '11 at 19:06
add comment

4 Answers

up vote 2 down vote accepted

3D Acceleration is "experimental" in VB and may not be properly supported. Also which version of Virtual Box are you using. The Open Source version doesn't seem to support all the functions of the one downloaded off the site.
I don't like suggesting closed source, but your situation may call for it.

Also I'm going to try running sudo apt-get install gnome-shell on my 11.10 machine and see what it looks like. There's still the possibility that it's not VB.

share|improve this answer
    
Version is 4.1.4, I've enabled hardware acceleration but still no result. –  Gabriele Cirulli Oct 28 '11 at 19:43
1  
Fixed it, I had to update to 4.1.4, reinstall the guest additions and remove and reinstall gnome-shell. –  Gabriele Cirulli Oct 28 '11 at 20:10
add comment

A video describing the process for using the Gnome shell in Fedora 16 can be found at http://www.squidoo.com/enable-the-gnome-shell-in-fedora-16-and-virtual-box (it should be similar for Ubuntu).

share|improve this answer
add comment

I have the latest version of VB and Gnome Shell is not working. I am getting the same thing you are getting, a desktop that looks like Gnome 2. I have enabled 3D A and I have given 128MB for video to the VM without luck.

share|improve this answer
    
Try to remove gnome shell, install the guest additions, reboot and reinstall gnome shell. Should work. –  Gabriele Cirulli Oct 30 '11 at 18:10
add comment

If it's just the Unity look in the VM you're wanting, try Unity-2D. It uses QT and has none of the OpenGL requirements which are likely why you're unable to have Unity in the VM. It looks almost exactly like Unity.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.