Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just done a fresh install of oneiric on a Dell Precision m6600 with a nVidia Quadro 3000m. I can log in to Unity 3D, but if I try to start nvidia-settings, I'm told "you do not appear to be using the nVidia X driver". Also, HDMI out doesn't work.

The automatically generated xorg.conf is very short and doesn't appear to be using the nVidia driver:

Section "Device"
    Identifier  "Default Device"
    Option  "NoLogo"    "True"
EndSection

However, if I run nvidia-xconfig, it will replace the xorg.conf with, among other things, Driver "Nvidia" line, but when I restart the computer, lightdm won't even start at all.

This all occurs whether I activate nvidia-current or nvidia-current-updates by the "Additional Drivers" GUI. In either case, the GUI says "This driver is currently activated and in use". (obviously not).

How should I go about getting nvidia-settings and HDMI-out to work? Thanks!

share|improve this question

1 Answer 1

For posterity:

Apparently I missed the memo where Quadro is only just beginning to be supported under Ubuntu. I disabled the Optimus feature in BIOS and reinstalled, and it worked fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.