Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

PCmanFM misses the permission column in its detail view and the ability to set viewable columns. Because of this I switched to Thunar. Now I want to set it as my default file manger in LXDE. How to do this?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

The simple way...

The quickest way is to create a pcmanfm shell script in /usr/local/bin. This shell script will instead execute thunar

Thus:

nano ~/pcmanfm

copy and paste the following:

#!/bin/sh
thunar $* &

Save

chmod 755 ~/pcmanfm
sudo mv ~/pcmanfm /usr/local/bin

The disadvantage though of this method is that you will lose any desktop shortcuts because on login, pcmanfm is no longer being run on login.

LXDE/XFCE Hybrid

A more interesting method would be to have the LXDE shell but with the XFCE desktop rather than the pcmanfm desktop

enter image description here

The reason for running with the xfdesktop is that it integrates with thunar whereas the pcmanfm desktop cannot be configured to launch folders stored on the desktop with thunar - only pcmanfm.

The recipe is as follows:

  • Change the default file-manager shortcut: edit the file /usr/share/applications/pcmanfm.desktop and change the line Exec=pcmanfm %U to Exec=thunar %U
  • Change shortcut keys: using leafpad change all references of pcmanfm to thunar in the file ~/.config/openbox/lubuntu-rc.xml
  • Stop pcmanfm desktop being run on login: edit the file /etc/xdg/lxsession/Lubuntu/autostart and change the line @pcmanfm --desktop --profile lubuntu to !@pcmanfm --desktop --profile lubuntu
  • Create a startup-on-login folder: create a folder called ~/.config/autostart
  • Start xfdesktop on login: create a file called xfdesktop.desktop in this autostart folder with...

the contents

[Desktop Entry]
Version=1.0
Type=Application
Exec=xfdesktop
Icon=help-contents
StartupNotify=false
Terminal=false
Categories=Utility;X-XFCE;X-Xfce-Toplevel;
Name=xfdesktop
  • Install xfdesktop: sudo apt-get install xfdesktop4
  • reboot.

a third way...

If you don't want to run the xfdesktop - then follow the recipe above, but dont disable pcmanfm in /etc/xdg/lxsession/Lubuntu/autostart and you also dont need to autostart xfdesktop.

Obviously you are still left with the folder on desktop launching pcmanfm issue - but if you can live with this, this is a worthy compromise.

share|improve this answer
    
shouldn' there be some "standart" way in LXDE? I was searchng but yesterday lxde.org was not available. –  Berov Oct 28 '11 at 9:12
    
A while back thunar was the default file manager for lubuntu. However I cant find any info on how the devs did the switch. I'll keep looking and post back if I find anything. –  fossfreedom Oct 28 '11 at 9:25
    
Thanks very much (just switched to XFCE :))! –  Berov Nov 5 '11 at 15:57
    
Which packages do I need to download in order to use option 2? –  arno Jul 29 '12 at 14:55
    
@arno - apart from thunar - you need xfdesktop4 as per the instructions. –  fossfreedom Jul 29 '12 at 18:56
show 1 more comment

For how to change and restore Default File Manager, check the link:

Ubuntu official documentation for Deafult File Manager

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.