Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Audio was working fine until I tried to use qjackctl and qsynth to play a MIDI keyboard. I followed this answer* to setup the keyboard and it worked. But then I noticed other applications couldn't play audio (VLC, Rhythmbox, etc.). After a reboot it was fine again. And then I set up the keyboard and the problem was back. This went on for a few days and I thought I could live with it as it fixed itself on reboot. But then it didn't. I couldn't play audio, except via qsynth and the MIDI keyboard. Now not even that audio will play.

*Mostly. qjackctl wasn't exactly as described, but I believe I found all the mentioned controls.

I'm not sure what I really did with qjackctl, or how to get back where I was. I tried removing (with apt-get purge) qjackctl and qsynth but that didn't help. Now I've reinstalled qjackctl and have tried changing the which driver is used by qjackctl, all to on avail.

Ideally I'd like the MIDI keyboard to work, but far more important is getting the audio back like it should be.

I've checked all volumes using alsamixer.

I believe JACK makes pulseaudio stop (see here and here, but I don't know how to stop jack and get it back to normal.

How can I make the audio work again?

share|improve this question
up vote 1 down vote accepted

Stop jackd by clicking "stop" in qjackctl or running this command in a terminal:
killall jackd
then if pulseaudio was stopped, run this command:
pulseaudio
"Standard" audio should be back.
Pulseaudio and jackd can run together installing pulseaudio-module-jack

EDIT : The real solution :
- try to install "pavucontrol" (pulse audio volume control) and check in output tab that main audio device is selected.

Also check configuration tab: This was the problem: Nateowami changed profile from "Digital Output (S/PDIF)" to "Analog Stereo Output" which solved the problem.

share|improve this answer
    
Thanks, but alas, I tried those. For the first one, jackd: no process found , and for the second, E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_create() failed. I've also run sudo service pulseaudio restart and it says stop: Unknown instance: pulseaudio start/running, process 10647. I think JACK is stopped and pulseaudio is running. Thanks for the answer though. – Nateowami Feb 6 at 10:03
    
You can try to install "pavucontrol" (pulse audio volume control) and check in output tab that main audio device is selected (also check configuration tab) . Also, in alsamixer, press F6 and check that you really control main soundcard (as most modern pc have another soundcard in hdmi output) – laugeo Feb 6 at 10:39
    
pavucontrol output tab says "Built-in Audio Digital Stereo (IEC958)" and is the only one shown (at the bottom it's set to show all output devices). Port is set to "Digital Output (S/PDIF)", which is the only option. When I play music in Rhythmbox both the Playback and Output Devices tabs in pavucontrol show audio volume rising and falling as the music plays. I tried muting and un-muting in both tabs. – Nateowami Feb 6 at 10:57
    
Then I went to the Configuration tab and switched the profile from "Digital Output (S/PDIF)" or "Digital Output (S/PDIF) + Analog Stereo Input" (can't remember which) to "Analog Stereo Output". Viola! It works! Thank you! I still don't know what caused the problem... – Nateowami Feb 6 at 10:58
    
cool, just accept the answer ! – laugeo Feb 6 at 11:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.