Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I messed up my xorg somehow and now unity-3d doesn't work, but unity-2d seems OK. By doesn't work, I mean that when I boot into 3d, I only see a background image, no icons, panels, or anything else.

What are the most likely suspects for why this would be the case? I would like to get 3d back to the way it was before I messed up my xorg (or whatever I messed up), and am looking for configuration files I could reset, or packages I could reinstall.

share|improve this question
    
possible duplicate of Resetting CCSM settings –  Bruno Pereira Oct 27 '11 at 21:23
add comment

2 Answers 2

up vote 1 down vote accepted

I want to point out for the sake of other users that the answer is more likely resetting Unity, as @brunopereira81 mentions below. So please, try that before tearing your hair out.

However, in my case, the answer was a need to downgrade the version of xorg and xserver-xorg. Once I did that, I had access to 3d again. (The answer to this question shows more of the background of how I went from a working installation to a broken one, and half-way back again) It ultimately stemmed from the xorg-edgers bug reported elsewhere.

Specifically, I had to reinstall xorg and xserver-xorg and ubuntu-desktop. After following a lot of recommendations on resetting compiz, dpkg-conf, etc, I found a couple key items:

  1. For me at least, sudo apt-get remove xorg xserver-xorg ubuntu-desktop was insufficient, as this did not remove dependencies, even with autoclean and autoremove run after.
  2. Rather, I had to use synaptic to do "complete remove" for each of these items.
  3. After complete removal, it finally also removed all the dependencies, and they were now the correct, rolled-back versions.
  4. Reinstalling ubuntu-desktop adds them back. There were about 5 items under xserver-xorg and xorg where it said it refused to install because another dependency was required. The solution to this was just to write down the name of the thing it would install, and select that before selecting the refusing item, which then allowed itself to be selected. It seemed strange to me this wasn't happening automatically, but there were only about 5 such cases, so it wasn't bad.

This series of operations fixed my 3d problems. (However, I am still having issues with libglib2 that will likely require a similar set of tracking down removals and installations.)

share|improve this answer
add comment

Compiz is the responsible for all the 3D nice effects in Unity. Its the probable responsible for this behavior, try to reset it.

unity --reset

Will reset your Unity settings in compiz.

unity --reset-icons

Will reset your dock bar icons to its original shape and config

gconftool-2 --recursive-unset /apps/compiz-1
unity --reset

Will reset all your compiz settings and unity plugin configuration to its original state.

Preferably use these on the terminal while not logged in to Ubuntu. At the login screen press ctrl+alt+F1 and login with your user. Try 1 of the commands and try to login again. If it does not work logoff and try the next one.

share|improve this answer
    
This was very helpful. I tried these, and agree they're the right approach, but the solution that helped me was different. Thanks! –  Mittenchops Oct 28 '11 at 12:57
    
Maybe you can post what happened and what had you did to solve it? –  Bruno Pereira Oct 28 '11 at 13:01
    
Fair point, updated my own answer below. =) –  Mittenchops Oct 28 '11 at 13:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.