Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install several packages older ones too.Tried to upgrade it from terminal,to compile it.Once I did it and wait it for long time,but at the end of instalation it showed me 2 errors.When I'm trying to run it from terminal with sudo inkscape I'm getting this message.

inkscape: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory

I tried to download inkscape with synaptic and ubuntu center too.Inkscape is awesome graphic tool,but I don't see how I could make it to work on Ubuntu 11.10.Thanx in advance.

share|improve this question
    
Any reason you're running it under sudo? –  Kris Harper Oct 27 '11 at 20:41
add comment

1 Answer

This bugreport suggests to do the following:

 sudo apt-get install --reinstall libgtkmm-2.4-1c2a

Please try this and see if it fixes your problem

Also, please don't run the inkscape command with sudo :)

share|improve this answer
    
Thanx a lot,your advice helped me to run inkscape from unity dashboard finaly.It was heavy,but as new ubuntu user I learned a lot while I was searching the solution to install inkscape.Again thanx a lot.Ubuntu developers made beautiful and very fast OS Ubuntu 11.10 –  Nikola Oct 28 '11 at 9:01
    
Glad to hear it solved your problem. You can accept this answer then so the question is no longer marked as unanswered. –  Sergey Oct 28 '11 at 21:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.