Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to record my Desktop and use zoom function. I changed Zoom in shortcut to <super>button5 and when I click Windows logo and scroll my mouse, it doesn't work. What I am doing wrong?

share|improve this question
    
Maybe it's not mouse button 5 but keyboard button 5, i.e. the number key for 5 on the keyboard? –  N.N. Oct 27 '11 at 19:19

2 Answers 2

up vote 2 down vote accepted

XServer interprets scrollwheel as extra mouse buttons; in Compiz, it's Button4 for Wheel Up and Button5 for Wheel Down - more details in Compiz wiki. This is for Compiz in Ubuntu 11.04, 11.10 may differ (although I doubt it).

I assume you have set up the shortcut using CompizConfig Settings Manager (ccsm). First make sure you have actually enabled the plugin you want to use for zooming. Also, as lgarzo suggests, try setting a different, non-conflict shortcut, possibly without a Super key - this key is a bit overloaded in Unity and sometimes just doesn't work for custom shortcuts.

EDIT: The problem was that Compiz wasn't actually running (see the comments below). Otherwise there's nothing wrong with Compiz zoom plugin.

share|improve this answer
    
Set upt alt button5, still not working... :/ –  mrSuperEvening Oct 27 '11 at 20:27
    
You could try a different plugin - in 11.04 there are "Zoom Desktop" and "Enhanced Zoom Desktop". What plugin do you use? What is the name of the entry you've setup the shortcut for? Or better yet - could you post a screenshot of the CompizConfig window where you set this shortcut? –  jnv Oct 27 '11 at 20:44
    
yes, give me two minutes. –  mrSuperEvening Oct 27 '11 at 20:47
    
    
I see... This should be okay, considering there are no conflicting shortcuts (which CCSM should warn you about) or that you're actually running Unity-2D :-) I know it sounds a bit Microsoft-y but have you tried to log out/in or to execute unity --replace? I used to have problem with Compiz not registering new plugins in Unity. –  jnv Oct 27 '11 at 20:59

It's the mouse scroll up direction.

Try Alt + Button5 instead.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.