Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running gksudo nautilus in the GNOME Shell changes my wallpaper from the GNOME 3 Stripes background to Ubuntu's warty final default background. I'm pretty sure this is related to root nautilus managing the desktop, but since I've recently upgraded from 10.04 and skipped 11.04, I'm unsure about what GNOME uses for settings now between dconf, gconf, etc, so I don't know where I can edit the setting to stop this. Any help would much appreciated.

share|improve this question
1  
this issue is present in a fresh install of 11.10 oneiric. i can confirm. –  suli8 Oct 27 '11 at 17:19

2 Answers 2

up vote 4 down vote accepted

Try to use gksudo -- nautilus --no-desktop instead.

The -- tells gksudo not to parse the remainder of the command line.

share|improve this answer

I was having the same problem, then remembered that I had installed the "Extended Places Indicator Extension." This extension has the option "Open File System as Root," which I can confirm doesn't mess with the wallpaper. Very nice extension with lots of other useful features.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.