Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is the error when I type gnome-screenshot:

$ gnome-screenshot
** DEBUG: The GetProfileForWindow request failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.ColorManager was not provided by any .service files

I installed gnome-color-manager, but that didn't fix the problem (I still can't take screenshots, and still get this error). All the search results I saw recommended changing xorg.conf, but I only have an xorg.conf.failsafe file, not an xorg.conf file.

share|improve this question
After installing gnome-color-manager, the error remains as: ** DEBUG: The GetProfileForWindow request failed: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /usr/bin/gcm-session: Success – Mittenchops Oct 27 '11 at 16:53
up vote 0 down vote accepted

This bug has been reported in the GNOME Bugzilla bug tracking system.

D-Bus allows programs to register with it in order to offer services. It also allows client programs to check for the availability of services.

The service is either not known for the DBus backend or it cannot be run for security reasons.

You can try to run the tool as root and see if it works.


share|improve this answer
Hmm, cool. Well, that's helpful, but I'm afraid that leaves me more confused. =) The program that caused this was gnome-screenshot, which worked until yesterday, so I know it should be a known service, right? – Mittenchops Oct 27 '11 at 17:22
Well, I could not guess from the question, but sure. If it worked yesterday I'd consider a few things. You might have updated packages that broke the tool, or the Update Manager installed something, you can check the logs. – lgarzo Oct 27 '11 at 17:51
Just tested myself, I have got the same debug message, but the screenshot tool works. Do you have any related error message in ~/.xsession-errors? – lgarzo Oct 27 '11 at 17:54
Yeah, that file has zillions of errors. Most concerning "org.ayatana.bamf.view" I know the screenshot is kind of working because it makes a sound, and gives me an image composed of a black page---it's just that it's only a black page, rather than what's on the screen. Anyway, in a sea of errors, which would you recommend I look for that might be best to explore getting a picture taken? – Mittenchops Oct 27 '11 at 20:28
Apart from renaming and creating an empty file here is a simple way: open terminal and type tail -f ~/.xsession-errors. Then press Enter a few times to separate previous entries. Now open a new terminal window and run gnome-screensot. Your previous terminal window will be updated with error messages that should be related to the problem. Press CTRL+C to stop the tail program. Here is my output for a comparison: – lgarzo Oct 28 '11 at 7:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.