Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Well, I've got a wired network on my Ubuntu 11.10 fresh installation. I can download files and surf the Internet. Problem is that sometimes it takes much time to load websites and sometimes it gives up trying. I also unsuccessfully tried to connect to an FTP server using Filezilla. The same wired network does work fine in a dual-boot installation of Windows 7. Please, help me configure my network appropriately.

Thanks in advance!


paulo@ubuntu:~$ sudo lshw -class network  
       description: Ethernet interface  
       product: RTL-8110SC/8169SC Gigabit Ethernet  
       vendor: Realtek Semiconductor Co., Ltd.  
       physical id: 4  
       bus info: pci@0000:04:04.0  
       logical name: eth0  
       version: 10  
       serial: 00:1d:60:55:58:5c  
       size: 100Mbit/s  
       capacity: 1Gbit/s  
       width: 32 bits  
       clock: 66MHz  
       capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation  
       configuration: autonegotiation=on broadcast=yes driver=r8169   driverversion=2.3LK-NAPI duplex=full firmware=N/A ip= latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s  
       resources: irq:16 ioport:e800(size=256) memory:febfec00-febfecff memory:febc0000-febdffff  
share|improve this question
Could tell if your wired connection "auto configured" or if you manually set it up? – lpanebr Oct 27 '11 at 13:56
please have a look at this question and add some details of your hardware and some logs to your question.… – fossfreedom Oct 27 '11 at 14:00
It was auto configured. As I said, it does work, but not as well as it is supposed to. – Paulo Lieuthier Oct 27 '11 at 14:20
up vote -2 down vote accepted

Try to disable IPv6 if you are not using it.

share|improve this answer

Maybe the kernel driver=r8169 in the kernel is not good enough, try compile the ralink drivers :

  1. First make a backup of your drivers first, to find where is the driver and backup it in a safe place.....:

sudo locate r8169.ko

  • Download the drivers here and select US1 server the other two doesn't work...
  • Prepare the system for compile :

sudo apt-get install build-essential linux-headers-$(uname -r) linux-source

  • Check whether the built-in driver, r8169.ko, is installed.

lsmod | grep r8169

  • If it is installed, please remove it.

rmmod r8169

  • compile the driver :
 tar jxvf r8169-6.015.00.tar.bz2 # unpack this on th desktop
 sudo mv r8169-6.015.00 /usr/src # move the drive directory from desktop to /usr/src
 sudo -i
 # navigate truth /usr/src/r8169-6.015.00
  • should be able to do (as root):
  make clean modules          
  make install
  depmod -a
  modprobe r8169
  • You can check whether the driver is loaded by using following commands.
  lsmod | grep r8169      
  ifconfig -a
  • Reboot

  • You can check whether the driver is loaded by using following commands.

lsmod | grep r8169

IF you cant find then, You might want to add r8169 to the list of modules which are loaded on startup. add this line at the end of the file :

sudo nano /etc/modules




enter image description here

  • Reboot

    1. If something go wrong or you only want revert this procedure or you don't agree with the result just restore the file that you backup in the first step....
share|improve this answer

I'm curious if you resolved this as i am having what i think is the same issue... network works fine for a moment, then will not respond at all for several minutes. active connections seem to be ok since i downloaded source code for several hours without fail, but new connections seem to be the problem and only sometimes.

UPDATE: disabling ipv6 didnt work for me. My solution for now was to install a spare Netgear 10/100 NIC in my motherboard until someone else fixes the realtek driver.

I have not tried hhlp's answer, but I needed this thing running ASAP so for now the spare card works great!

share|improve this answer
i have an integreated Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06) – Jason Nov 6 '11 at 14:05
i tried hhlp's instructions and it worked. I can't bump up his answer though... I had to download a different driver for my different adapter of course. – Jason Nov 11 '11 at 23:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.