Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Compaq Presario CQ60-307EA Laptop which has the Synaptics touchpad. It works fine, but one thing that's never worked is the disable button above it, which should completely turn off the touchpad. But when the disable button is pressed nothing happens, the light changes to orange like it should, but it isn't disabled and is still active.

I was wondering if anyone had got their Synaptics touchpad disable button to work. I find it strange as my friend has a Compaq Presario CQ61 which is a slightly different model, but still has the Synaptics Touchpad and his disable button worked fine, yet mine doesn't.

Any help on getting it to work would be great!

Thanks!

share|improve this question
1  
Oh yeah? On my system, it not only works, but it disables the keyboard too :) –  Nathan Osman Oct 14 '10 at 20:06
    
And yet my laptop decides I don't need the disable button functioning! –  James Oct 14 '10 at 20:11
    
This was also posted as a bug report: bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/… –  MagicFab Nov 16 '10 at 14:56
    
Yep, thats my bug report :) –  James Dec 15 '10 at 17:48
add comment

2 Answers 2

up vote 0 down vote accepted

I suppose the hotkey on your laptop is not recognized by Ubuntu (kernel or Xorg) yet. You might want to read the hotkey architecture overview and troubleshooting guide and file a detailed bug report if you find out what's wrong.

share|improve this answer
    
Thanks for the guides, they have helped me semi fix the problem. I posted my steps in a new post. –  James Oct 15 '10 at 10:07
    
-1 not an answer. please provide detailed steps rather than links. I'll remove the -1 if you add some of the details in those post. –  Henrik Jan 31 '11 at 18:44
    
@Henrik: I used those links because that way people (hopefully) find up-to date information. I also don't see the point in copy-pasting hundreds of lines of text and some images from the Ubuntu wiki here... –  JanC Feb 2 '11 at 2:21
add comment

JanC thanks for posting those guides. I have semi fixed the problem, so I thought I'd post the answer in a seperate post.

Basically what I've done is use gconf-editor to go to: /apps/gnome_settings_daemon/keybindings

Looking at the TouchPad entry the default was "XF86TouchpadToggle". However, after creating a keyboard shortcut for the touchpad disable button registered as Help not XF86TouchpadToggle, so I've now changed the value to Help in gconf-editor and my disable button works. The only problem is I have to press the disable button twice for it to be disabled and like wise to re-enable the device.

It does work now though, which is something. It even registers the disabling and re-enabling of the touchpad with a notification in the top right, which is pretty cool.

share|improve this answer
    
Not sure if you filed a bug about this, but this can probably be fixed if you do. Once it's fixed the key won't work anymore until you change is back to "XF86TouchpadToggle" though... ;) –  JanC Feb 2 '11 at 2:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.