Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Problem with gnome3-shell (top taskbar)

I have new Ubuntu 11.10 and I installed gnome-shell instead Unity. I want to add some icons to desktop, but when I enable file manager to handle the desktop in Ubuntu tweak I get file manager panel under the Gnome shell main panel.

Is there way to delete this file manager panel and still have icons on the desktop?

enter image description here

share|improve this question

marked as duplicate by jrg, Octavian Damiean, Jjed, Takkat, Bruno Pereira Feb 3 '12 at 0:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

What I see in the screenshot is just the file manager menu, which, along with other menus shows in the top panel by default. AFYI, Unity uses the same file manager as Gnome Shell, it's called Nautilus. Do not remove it!

What you need to do is remove the Global Menu integration:

sudo apt-get autoremove appmenu-gtk appmenu-gtk3 appmenu-qt

For Firefox, either disable the Global Menu addon:

“Tools -> Add-ons -> Extensions”. Disable the “Global Menu Bar Integration” extension

or remove it: sudo apt-get purge firefox-globalmenu.

share|improve this answer

Mabye removing appmenu-gtk3 and restarting nautilus will solve your problem:

sudo apt-get remove appmenu-gtk3
nautilus -q
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.