Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11.10 and I can log in lightdm successfully.

But if I log in Ubuntu in remote client via VNC or Xrdp, the desktop is very weird. Please check the screen-shot below.

enter image description here

I used apt-get to install tightvncserver and xrdp, all settings by default.

Anyone knows how to fix it? Thanks in advance!

share|improve this question
    
can you add the your .vnc/xstartup config? –  user44714 Feb 2 '12 at 19:35
add comment

1 Answer 1

up vote 4 down vote accepted

You need to provide the session properly. Unity is the default shell in Ubuntu, and since it cannot be used with RDP and similar, it will fail to start when you use the default Gnome Session. Therefore you need to add --session=ubuntu-2d to the session preferences. That will tell it to use Unity 2D instead of Unity.

share|improve this answer
    
Thank you. I set the session to ubuntu-2d, then I can view the desktop normally. –  Landy Oct 28 '11 at 3:21
    
I have the same problem, could you tell me where is the session preferences file located? Or in other work –  user37007 Dec 7 '11 at 15:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.