Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been working (on and off) for about 2 weeks now and I'm still stuck in 800x600...

I followed this guide as well as i could but when I got to:

sudo apt-get install xorg-emgd emgd-dkms

It returns:

E: Unable to locate package xorg-emgd
E: Unable to locate package emgd-dkms

I'm fairly new to Linux and i have tried to make the switch before. I feel like I'm really making headway this time though and I"m starting to like the way things work in Linux. (this is just so you understand my knowledge of Linux better)

Any help is REALLY appreciated even if its just blind suggestions or other helpful hints, I know the GMA500 is a bit of a... well people don't seem to like it that much...

if you need/ want any additional info just ask. :)

after trying the solution to a similar post:

sudo add-apt-repository ppa:gma500/ppa 
sudo apt-get update 
sudo apt-get install poulsbo-config poulsbo-driver-2d poulsbo-driver-3d

The update step gives me:

W: Failed to fetch http://ppa.launchpad.net/gma500/ppa/ubuntu/dists/oneiric/main/source/Sources  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/gma500/ppa/ubuntu/dists/oneiric/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

and the install step gives me:

E: Unable to locate package poulsbo-config
E: Unable to locate package poulsbo-driver-2d
E: Unable to locate package poulsbo-driver-3d

I am beginning to think I am missing something simpler than I think in these instructions... (the "duplicate" post links to the same instructions I stated preciously don't work)

share|improve this question
    
    
In the duplicate entry there is an answer (askubuntu.com/questions/45037/…) that seems to work. If it does, please upvote it, it needs it to jump to the top. If it doesn't at least leave a comment there. –  Javier Rivera Oct 27 '11 at 7:13
add comment

2 Answers

up vote 3 down vote accepted

Edit: There is a custom Oneiric ISO with EMGD and all the needed modifications. You might want to try that first. http://ubuntuforums.org/showpost.php?p=11356431&postcount=4605

You've been trying to follow older howtos, none of which claim to be a solution for Ubuntu 11.10. Look closely, the EMGD PPA only claims support upto Natty, aka Ubuntu 11.04. The second guide suggests installing the old PSB driver, which worked starting from 9.04 through 11.10, thanks the community efforts, but has become impractical to support without Intel's contribution. There simply aren't any PSB packages for Oneiric.

People like GMA500 very much, if only Intel would provide a working Linux driver, open or closed, same as for its other chipsets.

Some claimed to have gotten 11.10 partially working with gma500:
http://ubuntuforums.org/showpost.php?p=11378988&postcount=4643

1. boot from standard install cd in live mode (F6) with "poulsbo.asd=1 psb_gfx.asd=1" added to kernel string
2. select install ubuntu from livecd
3. boot selecting unity-2d and install updates
4. make unity-2d default interface

sudo sed -i 's/user-session=ubuntu/user-session=ubuntu-2d/g' /etc/lightdm/lightdm.conf

5. perform emgd install and reboot

sudo add-apt-repository ppa:gma500/emgd-1.8
sudo apt-get update
sudo apt-get install xorg-emgd emgd-dkms
sudo emgd-xorg-conf

6. still won't boot so blacklist other modules and disable plymouth

sudo echo "# EMGD" >> /etc/modprobe.d/blacklist.conf
sudo echo "blacklist psb_gfx" >> /etc/modprobe.d/blacklist.conf
sudo echo "blacklist poulsbo" >> /etc/modprobe.d/blacklist.conf
sudo echo "emgd" >> /etc/modules
sudo mv /etc/init/plymouth.conf /etc/init/plymouth.conf.disabled

now it works, sort of, here are my problems:

1. LibreOffice is way too slow, especially Calc
2. Playing videos from youtube, etc.. is impossible, sound sync is lost immediately
3. General performance of the system is kind-of slow, but within expected netbook range (I used have an older AspireOne, and it was a little better than 1101HA after the RAM upgrade)
share|improve this answer
    
first off, thank you for your help :) secondly as I said before I'm kinda new to Linux, if i could get so help on the: (boot from standard install cd in live mode (F6) with "poulsbo.asd=1 psb_gfx.asd=1" added to kernel string) just a slightly more detailed explanation on this bit would be awesome –  Bendude137 Oct 27 '11 at 17:53
    
The GMA500 megathread from ubuntuforums.org has most of the answers. Here is how to add boot options: ubuntuforums.org/showpost.php?p=11311770&postcount=4559 Troubleshooting is a great way to learn Linux, but I am afraid the learning curve will be rather steep. –  mikewhatever Oct 27 '11 at 18:18
    
I'm trying that costume ISO right now ill report back in a bit :) –  Bendude137 Oct 28 '11 at 5:49
    
WooHoooo! I tried the modified liveCD and its working GREAT, it even fixed the sound problem I was having. THANK YOU! (I'll make sure to come back and vote up you answer when I get more rep) –  Bendude137 Oct 28 '11 at 7:10
add comment

Try this:

sudo add-apt-repository ppa:gma500/emgd
sudo apt-get update
sudo apt-get install xorg-emgd emgd-dkms
sudo emgd-xorg-conf

Reboot for the changes to take effect.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.