Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

logged into my ubuntu account and found myself on a screen with just my desktop background and nothing else.

pressing the volume buttons displays the indicator, and i can get to a tty session but i can't do anything else. restarting gdm doesn't seem to help at all either

I'm running 11.10, upgraded from a wubi install of 11.04.

any thoughts?

share|improve this question
    
try running lightdm from the tty –  JesusLives ii Oct 27 '11 at 2:53

3 Answers 3

up vote 2 down vote accepted

Greg, not knowing which default DM you are using, it could be several things at fault. Unfortunately lacking enough information to answer with confidence, but would suspect that the desktop-manager session has become a mess somehow.

Knowing what was occurring prior to the problem would be helpful. Was this just post-upgrade or had there been recently installed packages, or was there something else occurring prior to login?.

Depending on which DM you are using by default (gnome-shell or unity) you might want to drop down into a recovery console and try to reset the DM, if you believe that is the root of the problem.

Know that the command: unity --reset should restore the unity DM defaults, but have not had any luck while the X server is running and trying that command from a tty.

Seems it does not quite finish. Know there is a command to replace the gnome-shell as well, and if you should also load the gnome-session-fallback just in case. HTH, not sure if this answers, but trying to.

share|improve this answer
    
unity --reset mostly worked. Going to reset and see if it's fully fixed. It did throw a bunch of this though: "compiz (core) - Warn: unhandled ConfigureNotify on 0x4e00099! compiz (core) - Warn: this should never happen. you should probably file a bug about this. –  greg Oct 27 '11 at 4:37
    
seems fully fixed. thanks. –  greg Oct 27 '11 at 4:41
    
Just wanted to add that if you have problems with the launcher, unity --reset-icons is also useful. –  Jo-Erlend Schinstad Oct 27 '11 at 18:18

I've just had the same problem - no window manager, no decoration, no apps started, and only an Xterm! It turned out, that I had somehow, (clumsiness comes to mind) selected "Recovery Session" under the Gear symbol on the Login screen. I changed it to "Ubuntu", and when I logged in, everything was back. Log out, and click on the Gear!

share|improve this answer
    
i wasn't in recovery mode. It was a regular session with no window manager. –  greg Oct 27 '11 at 4:40

Right click on your desktop background, if a menu pops up, create a new folder.

Double click on the folder and a nautilus window should pop up. Browse to location /usr/share/applications and find program Compiz, double click on it and magic might happen.

If nothing really happens, go into CompizConfig Settings Manager and check if the Unity Plugin is enabled. If you don't have this program, open a Terminal, and run command: sudo apt-get install compizconfig-settings-manager or if you dont even have Compiz, run command: sudo apt-get install compiz


If no menu pops up, go to a tty session, login and run commands:

sudo killall lightdm
startx

If that doesn't seem to work either, check if unity and compiz are installed. Run commands from a tty session:

sudo apt-get install compiz unity

Hope that helps :P

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.