Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can change the background image that LightDM displays, but regardless of the image I choose, it's overlaid with a grid of dots. The dots look OK on the default background, but they look horrible on the background I want to use. How can I get rid of them? There don't appear to be any relevant options in any of the files in /etc/lightdm.

share|improve this question
add comment

4 Answers 4

up vote 15 down vote accepted

For 12.04

Try the following commands in a terminal. It should work.

sudo xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter draw-grid false
exit

References:

share|improve this answer
    
+1 for giving the correct answer for 12.04. I'd remove the second exit though, it assumes that you opened a terminal just for this sequence of statements and want to close it again. –  nem75 Apr 22 '12 at 10:40
    
@nem75 Thanks. Sorted it out. –  jokerdino Apr 22 '12 at 11:19
    
For some reason this worked on one 12.04 machine but not on another. –  detly Sep 2 '12 at 4:38
    
@detly If it doesn't work in one machine, I am not exactly sure if my answer is wrong. Can you give us more info? –  jokerdino Sep 2 '12 at 4:54
    
Sorry, I accidentally submitted that comment before I meant to. I found that the Ubuntu Tweak Tool has a toggle for it anyway, which worked for me. –  detly Sep 2 '12 at 5:04
show 2 more comments

This answer applies only to Ubuntu 11.04

Thanks to @Blitz and @Zoke for their answers. However, I've created a more complete solution. I've modified the package unity-greeter to remove the dots and I've packaged it in a PPA.

Anyone who wants to be rid of the dots can use my PPA. Here are instructions:

  1. Add the PPA:

    sudo add-apt-repository ppa:scott.severance/lightdm
    
  2. Run sudo apt-get update

  3. Run sudo apt-get upgrade
  4. The dots are now gone.
share|improve this answer
    
Nice work thanks for sharing –  Blitz Oct 30 '11 at 14:56
3  
If you downvote, please explain why. –  Scott Severance Jan 19 '12 at 16:23
2  
Presumably because forking unity-greeter is overkill, and relying on a PPA to maintain an important package (even if unity-greeter is mainly just configuration) is not ideal. And there is a much simpler configuration-only solution. –  neon_overload Apr 22 '12 at 12:37
4  
@mmj: At the time this was posted, it was the only way. I filed a bug containing my patch which was accepted upstream. Now, upstream has changed the way they handle configuration. I fail tosee how my solution was o erkill –  Scott Severance Apr 22 '12 at 13:35
add comment

It is hard coded in the sources. I have disabled it on my install by making a small change in the source of user-list.vala.

A quick step by step guide.

sudo apt-get install build-essential
apt-get source unity-greeter
sudo apt-get build-dep unity-greeter
cd unity-greeter-0.1.1/src/
vim user-list.vala +252

Remove the line or just add // at the beginning of the line. Save and exit.

cd ..
dpkg-buildpackage -rfakeroot -uc -b
cd ..
sudo dpkg -i unity-greeter_0.1.1-0ubuntu1_*.deb

Ubuntu will try to replace the custom built package when performing a system upgrade. Just uncheck unity-greeter to keep the custom one or reinstall the custom one using 'dpkg' after the upgrade.

[Edit]

To prevent the package manager from replacing your custom unity-greeter just run

sudo apt-mark hold unity-greeter
share|improve this answer
    
Thanks for your answer. As you were posting, I was working on this, also. I've now posted the result in a PPA, as explained in my answer. Had I not been working on a more complete solution, I would have accepted your answer. –  Scott Severance Oct 30 '11 at 9:51
    
No problem. A more permanent solution is always welcome. After all not all of us are comfortable working with source code. –  Zoke Oct 30 '11 at 12:19
add comment

At the moment at least this is not currently possible. I have done some reading around before and it seems to be hard coded in. Hopefully the devs will include a way to get rid of them eventually.

share|improve this answer
2  
Your answer spurred me to examine the source. The grid is in fact hard coded in the file src/user-list.vala. Line 233 is the most interesting. If I get time, perhaps I'll turn the alpha all the way down and make a .deb with the modifictions. –  Scott Severance Oct 27 '11 at 4:20
    
It is possible in 12.04 via gconf settings. –  nem75 Apr 22 '12 at 10:41
add comment

protected by Community Mar 13 '12 at 3:42

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.