Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've seen this answer and this one. I think I've done what they say to do, but I'm still having trouble.

I've copied /usr/share/applications/gnome-terminal.desktop to ~/.local/share/applications/. I then edited that file to look like this

[Desktop Entry]
Name=Terminal
Comment=Use the command line
TryExec=gnome-terminal
Exec=gnome-terminal
Icon=utilities-terminal
Type=Application
X-GNOME-DocPath=gnome-terminal/index.html
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-terminal
X-GNOME-Bugzilla-Component=BugBuddyBugs
X-GNOME-Bugzilla-Version=3.0.1
Categories=GNOME;GTK;Utility;TerminalEmulator;
StartupNotify=true
OnlyShowIn=GNOME;Unity;
X-Ayatana-Desktop-Shortcuts=New;NewDev
X-Ubuntu-Gettext-Domain=gnome-terminal

[New Shortcut Group]
Name=New Terminal
Exec=gnome-terminal
TargetEnvironment=Unity

[NewDev Shortcut Group]
Name=New Development Terminal
Exec=gnome-terminal --window-with-profile=Development
TargetEnvironment=Unity

I then chowned the file to make me the owner instead of root. I closed all my terminals and removed the terminal icon from the launcher.

Now, if I open Terminal from the dash, I get a new launcher icon which has the new quicklist. But if I press Ctrl + Alt + T, it opens a different terminal icon, which doesn't have the quicklist.

What's worse is that if I keep the new icon in the launcher and then close all terminals, using the new quicklist opens a new terminal with the correct profile, but with a new icon without the quicklist.

I made a video here of some of the weird behavior.

I also tried editing the /usr/share/applications/ file directly, but that didn't work at all. I got no new quicklist, and clicking on the launcher icon wouldn't load a terminal at all.

What am I doing wrong in creating quicklists?

share|improve this question
    
There doesn't appear anything wrong with your .desktop. –  doug Oct 27 '11 at 2:38
    
Sorry about 2 comments - don't get how they work here. Anyway - Try removing your current launcher icon, then log out/in. After that browse to ~/.local/share/applications & drag that .desktop you created on to the launcher. (All my terminal quicklists are controlled by the same icon, as is Crtl+Alt+T –  doug Oct 27 '11 at 2:47
    
@doug Just tried this. When I use the quicklist to open a new profile Terminal it opens in a new launcher icon. Ctrl + Alt + T also opens in a new launcher icon. –  Kris Harper Oct 27 '11 at 23:02
    
Can't dup that here, it sounds like you're getting a new process for each of your variations, this would give you new 'running' icons. Have you checked that? –  doug Oct 28 '11 at 1:38
    
@doug I don't think it's spawning a new process, because the old icon never has anything running. All of the terminals get grouped into one icon. I made a video here showing some of the behavior. –  Kris Harper Oct 28 '11 at 2:16
add comment

2 Answers

up vote 2 down vote accepted

What I think you should try is this -

Open your custom gnome-terminal.desktop in a text editor

Remove this line & it's space entirely, then save. You may want to then do a log out/in & try again

OnlyShowIn=GNOME;Unity;
share|improve this answer
    
I'll try this when I get home, but that line is there in the default .desktop file. The only lines I changed are X-Ayatana-Desktop-Shortcuts=New;NewDev and the last five lines. –  Kris Harper Oct 28 '11 at 20:55
    
Wow, this worked! Thank you very much. –  Kris Harper Oct 28 '11 at 22:29
    
It's 'okay' for that line to be in the installed .desktop, not so when it's in an alternate location. This will also affect other modded .desktop, nautilus-home is another –  doug Oct 29 '11 at 0:14
add comment

Its not a problem with quicklists, Ctrl + Alt + T appears to be hard coded to the gnome-terminal command. I confirmed this by creating a gnome-terminal symlink in my ~/bin and binding it to a different executable.

To work around this you can create your own short cut with your custom command in System Settings -> Keyboard -> Shortcuts -> Custom Shortcuts, as the system commands cannot be edited save for changing the shortcut keys

This will disable the current Terminal Launcher shortcut, if you use the same command.

share|improve this answer
    
It's more than that though. Once I have my quicklist working, if I use it to open a new profile terminal, it will open in another launcher icon. Strangely, this only happens if there aren't any terminal windows open, otherwise it'll just join the currently open terminal icon. –  Kris Harper Oct 27 '11 at 1:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.