Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just got a new keyboard, the Microsoft comfort curve 2000, and everything seems to work fine except for the 'back' and 'forward' multimedia keys.

I am running Ubuntu 11.10 and have tried going into system settings -> keyboard -> shortcuts, then I try and hold down the keys to set the action I want them to perform, but nothing changes.

Any thoughts on where else to look?

-- UPDATE --

I rebooted and the options to change the keyboard shortcuts seem to be working now. Now I can tweak the whole thing and I managed to assign the media keys correctly.

Thanks to everybody for the suggetions

share|improve this question

closed as off-topic by Braiam, bain, neon_overload, Victor9098, chaos Jul 11 at 11:57

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This question is about an end of life Ubuntu release. These are no longer supported and are therefore off-topic here. To upgrade, see: How to install software or upgrade from old unsupported release?" – neon_overload, Victor9098, chaos
  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Braiam, bain
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
    
File a bug report on Launchpad. Include output from sudo lsusb --verbose. –  Anonymous Oct 26 '11 at 21:51
    
Ubuntu 11.10 is definitely too damn old. Please upgrade. –  neon_overload Jul 11 at 4:55

3 Answers 3

up vote 4 down vote accepted

Try the following; consider them as different tests.

  1. Run showkey (will perhaps require root privileges). This application will tell you if your key is being read or ignored by the system.
  2. Install and run dconf-editor. Go to org.gnome.settings-daemon.plugins.media-keys and set next to XF86AudioNext and prev to XF86AudioPrev.
share|improve this answer
    
According to showkey the keys are being read 'keycode 158' for back and 'keycode 159' for forward. Should I input those to dconf-editor or the codes you suggested? The media keys are currently set to your suggestions –  Victor9098 Oct 26 '11 at 22:45
    
I was thinking about that. I don't think so, I just suggested the application so you could see if your key presses were being read. I think that the solution might be to assign the the XF86 fake keys to your keycodes. I have no idea how to do that, but I think it has to do with xmodmap –  Wolter Hellmund Oct 27 '11 at 4:08
    
Check either the manual or this website: xfree86.org/4.2.0/xmodmap.1.html You can set fake keys (keysyms) to keycodes, but perhaps it is a better idea to find out how to get your system to match the correct keyboard. –  Wolter Hellmund Oct 27 '11 at 4:27

Seems like the 11.10 upgrade resets the keyboard layout setting in System Settings. The Single Quote (') and Double Quote (") buttons besides a few others was not working for me subsequent to the upgrade.

I had to go to System Settings > Keyboard > Layout Settings and add English (US) from the list and remove the English (International with dead keys) choice.

Is this a bug in the upgrade?

share|improve this answer

Check you have the right keyboard model selected. System Settings->Keyboard->Layouts->Keyboard Model->Microsoft Curve 2000

(I'm on 11.04 and this keyboard is listed so it should be on 11.10)

share|improve this answer
    
They do not list the keyboard makes in 11.10 from what I can see, just the language and then the list of variations, nothing to set the specific keyboard make/model. Like I said above, you can go into the keyboard settings and should be able to assign the keys but when I assign them for the keyboard nothing changes –  Victor9098 Oct 26 '11 at 22:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.