Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Why is the Update manager of my Ubuntu 11.04 say "There are no updates to install"?

And no message "New Ubuntu release '11.10' is available" is displayed?

In software sources it is set to "Normal Releases".

What am I missing?

share|improve this question
add comment

3 Answers

It's possible that Update Manager is checking for LTS releases only or no releases. In software properties (sudo software-properties-gtk), on tab Updates, check the last option - Release upgrade. It should be set to Normal releases.

Also try running sudo update-manager --check-dist-upgrades and make sure you have all packages up-to-date (especially for Update Manager).

There are more upgrade strategies at https://help.ubuntu.com/community/OneiricUpgrades

If nothing of this helps, try updating package information from console - what's the output of sudo apt-get update command?

Edit: The Maurizio's problem was caused by outdated mirrors. The mirror can be changed in Software Properties on the first tab, in Download from select Main server.

share|improve this answer
    
sudo software-properties-gtk --> Normal releases –  Maurizio Oct 26 '11 at 22:08
    
sudo update-manager --check-dist-upgrades --> Your system is up-to-date; sudo apt-get update --> list of Http:// .. ; is the alternate CD the only way out ? –  Maurizio Oct 26 '11 at 22:20
    
Regular install CD/flash disk should offer an option to upgrade the installed system - just boot from it, run installation and the option to upgrade should be offered to you. There're some more options mentioned at help.ubuntu.com/community/Upgrades I guess there's something fishy with your Update Manager or maybe you're using a stale mirror (this can be changed in Software Properties). –  jnv Oct 27 '11 at 20:36
1  
Thanks a lot. Your suggestion about "using a stale mirror" did ring me a bell. It was enough to change the mirror in the settings(now Main server). Now 11.10 is available. Thank again. –  Maurizio Oct 28 '11 at 17:49
    
Glad to see it worked out well. I've added the solution to my answer so if it worked for you, please mark the correct answer as accepted. –  jnv Oct 28 '11 at 18:17
show 5 more comments

First go in your file /etc/apt/sources.list logged as root and check of all main ubuntu packages didn't have # at the beginning of line. If yes, remove the #'s.

Then do sudo apt-get update

And finally sudo apt-get dist-upgrade

If it finds new packages, mainly the kernel modules, and you install them, you will get the new ubuntu.

share|improve this answer
    
The only packages with # are the software from the 'backports' repository and deb-src archive.canonical.com/ubuntu natty partner. Do you think those packages are relevant ? –  Maurizio Oct 28 '11 at 17:38
    
Strange...can you post your /etc/apt/sources.list in pastebin and give the link here? Backports isn't needed packages, but, maybe it's necessary. Did you tried dist-upgrade command? What you got? –  GarouDan Oct 29 '11 at 0:21
    
    
It's very strange. But, for my experience, it's better you don't upgrade to the newer version using dist-upgrade. Several applications starts crashing and dpkg-reconfigure didn't fix. If you would like use the new Ubuntu I recommend format and put a new one. Other thing, by your pastebin code, looks like you have already updated to the newer version of ubuntu. For you comprove that type cat /etc/issue and post what you got. –  GarouDan Oct 29 '11 at 23:30
    
maurizio@mogs-W510:~$ cat /etc/issue Ubuntu 11.04 \n \l –  Maurizio Oct 30 '11 at 19:46
add comment

There is a choice in software sources if you want to be notified of normal releases or just LTS releases. Perhaps you've opted to only be notified of LTS releases?

share|improve this answer
    
Unluckily no : Normal releases is the choice –  Maurizio Oct 28 '11 at 19:08
    
What mirror do you use? Is it possible that it hasn't synced, for some reason? –  Jo-Erlend Schinstad Oct 29 '11 at 7:21
    
I have changed the mirror more than once. Nopw it is Main server –  Maurizio Oct 29 '11 at 19:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.