Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a hp dv4 running Ubuntu 11.10. The sound is fine when the speaker is on and the volume control works fine too. But when I plug in the headphones, the sound gets muted. Even if I change the volume to max, the indicator LED show's that its muted. Is this a bug?

share|improve this question

5 Answers 5

up vote 6 down vote accepted

I have the same issue (also on hp dv4 running 11.10, worked fine on 11.04). I just tried the following and it worked for me.

Go to 'sound settings' and click on 'output'. There you will see 'analog headphones' for the connector (at the bottom). Change that to 'analog speakers' and you will get sound on your headphones.

Strange, but it works.

share|improve this answer
1  
I had another weird problem the other day: with headphones plugged in, sound played thru them, and also the speakers. I fixed it by changing the output in sound settings. :) –  Matt Oct 27 '11 at 4:17
    
hey it worked :D thank you :D –  Gayathri Oct 27 '11 at 7:16
    
Its just the ooposite for me... Analog Speakers send the sound from laptop speakers, but as analog headphone... no sound at the line-out speakers/headphone –  Starx Feb 5 '12 at 18:46

In Kubuntu 12.04 after upgrading to Firefox 15 requiring an Adobe Flash upgrade I noticed several of my sound drivers replaced and removed without my authorization. I could use my speakers but when plugging in the headphones the sound muted.

I found the answer here after an hour of searching. Lots of Linux people just don't want to give a direct and simple answer about anything which really hurts the Linux promotion effort.

Go to the menu Settings -->
sub-menu System Settings -->
tab Audio Hardware Setup -->
select speakers in the connector pull-down -->
click button lower right Apply.

Your headphone plug ins will no longer mute the sound.

share|improve this answer

Change your audio settings in Sound Settings: change your main output from speakers to headphones.

share|improve this answer

Installing the "crack of the day" alsa-driver code solved the problem for me.

I don't know if my problem was exactly the same as yours, but my headphone sound was very quiet, even when I cranked the volume to maximum.

Martin's workaround of going to the sound settings and switching output from analog headphones to analog speakers worked for me, but it was irritating to have to switch every time I plugged in headphones.

I reported a bug, and then found a similar bug with a workaround of installing the "crack of the day" alsa-driver code.

share|improve this answer

Go to 'sound settings' click on 'Input' and unchecked mute at the tail end of 'Input Volume' and change the 'Connector' to Analogue Microphone to see if it was still doing the same things as before.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.